aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docker.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docker.scm')
-rw-r--r--gnu/packages/docker.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/docker.scm b/gnu/packages/docker.scm
index eb76b85676..bb981665d6 100644
--- a/gnu/packages/docker.scm
+++ b/gnu/packages/docker.scm
@@ -91,6 +91,8 @@ pseudo-terminal (PTY) allocated to a Docker container using the Python
client.")
(license license:asl2.0)))
+;; When updating, check whether python-jsonschema-2.6 can be removed from Guix
+;; entirely.
(define-public docker-compose
(package
(name "docker-compose")
@@ -107,9 +109,10 @@ client.")
(arguments '(#:tests? #f))
(inputs
`(("python-docker-py" ,python-docker-py)
+ ("python-docker-pycreds" ,python-docker-pycreds)
("python-dockerpty" ,python-dockerpty)
("python-docopt" ,python-docopt)
- ("python-jsonschema" ,python-jsonschema)
+ ("python-jsonschema" ,python-jsonschema-2.6)
("python-pyyaml" ,python-pyyaml)
("python-requests" ,python-requests-2.7)
("python-six" ,python-six)
021-02-19 20:10:08 +0100'>2021-02-19tests: Export %simple-os....* gnu/tests.scm (%simple-os): Export it. Mathieu Othacehe 2020-07-25utils: Move <location> and '&error-location' to (guix diagnostics)....* guix/utils.scm (<location>, source-properties->location) (location->source-properties, &error-location): Move to... * guix/diagnostics.scm: ... here. * gnu.scm: Adjust imports accordingly. * gnu/machine.scm: Likewise. * gnu/system.scm: Likewise. * gnu/tests.scm: Likewise. * guix/inferior.scm: Likewise. * tests/channels.scm: Likewise. * tests/packages.scm: Likewise. Ludovic Courtès