aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/docbook.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/docbook.scm')
-rw-r--r--gnu/packages/docbook.scm17
1 files changed, 15 insertions, 2 deletions
diff --git a/gnu/packages/docbook.scm b/gnu/packages/docbook.scm
index 889bb96010..e348fb1a5b 100644
--- a/gnu/packages/docbook.scm
+++ b/gnu/packages/docbook.scm
@@ -5,6 +5,7 @@
;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2020 Marius Bakke <marius@gnu.org>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
+;;; Copyright © 2021 Mark H Weaver <mhw@netris.org>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -33,6 +34,7 @@
#:use-module (guix licenses)
#:use-module (guix packages)
#:use-module (guix download)
+ #:use-module ((guix build utils) #:select (alist-replace))
#:use-module (guix build-system trivial)
#:use-module (guix build-system python))
@@ -249,7 +251,7 @@ by no means limited to these applications.) This package provides XML DTDs.")
(inputs
`(("docbook-dsssl-doc" ,docbook-dsssl-doc)))
(native-inputs
- `(("bzip2", bzip2)
+ `(("bzip2" ,bzip2)
("tar" ,tar)))
(home-page "https://docbook.org/")
(synopsis "DSSSL style sheets for DocBook")
@@ -287,7 +289,7 @@ by no means limited to these applications.) This package provides XML DTDs.")
"--no-same-owner" "-C" docdir
(string-append "docbook-dsssl-" ,version "/doc"))))))
(native-inputs
- `(("bzip2", bzip2)
+ `(("bzip2" ,bzip2)
("tar" ,tar)))
(home-page "https://docbook.org/")
(synopsis "DocBook DSSSL style sheets documentation")
@@ -460,3 +462,14 @@ process. MathML 2.0 markups are supported too. It started as a clone of
DB2LaTeX.")
;; lib/contrib/which is under an X11 license
(license gpl2+)))
+
+;; This is a variant of the 'dblatex' package that is not updated often. It
+;; is intended to be used as a native-input at build-time only, e.g. by
+;; 'gtk-doc' for generating package documentation. This allows the main
+;; 'dblatex' and 'imagemagick' packages to be freely updated on the 'master'
+;; branch without triggering an excessive number of rebuilds.
+(define-public dblatex/stable
+ (hidden-package
+ (package/inherit dblatex
+ (inputs (alist-replace "imagemagick" `(,imagemagick/stable)
+ (package-inputs dblatex))))))
2023-07-01gnu: catch2: Update to 3.3.2....* gnu/packages/check.scm (catch2-3.1): Rename to catch2-3.3. [version, source]: Update to 3.3.2. [outputs]: Remove ‘doc’. [build-system]: Use cmake-build-system. [arguments]: Remove special phases. Add CMake options to #:configure-flags. * gnu/packages/potassco.scm (clingo): Adjust accordingly. Signed-off-by: Liliana Marie Prikler <liliana.prikler@gmail.com> David Elsing 2023-06-24gnu: Add subunit....* gnu/packages/check.scm (subunit): New variable. Signed-off-by: Ludovic Courtès <ludo@gnu.org> Antero Mejr ss. * tests/boot-parameters.scm (%default-store-crypto-devices): New variable. (%grub-boot-parameters, test-read-boot-parameters): Use %default-store-crypto-devices. (tests store-crypto-devices): New tests. Miguel Ángel Arruga Vivas 2020-12-15Revert "gnu: grub: Fix unicode font loading when booting over TFTP."...This reverts commit 03fb57ff77b57de510b59485845ed7cb4e0a77a7, which breaks most system tests. Specifically, grub.cfg.drv fails to build: ERROR: In procedure canonicalize-path: In procedure canonicalize-path: No such file or directory Ludovic Courtès 2020-12-14gnu: grub: Fix unicode font loading when booting over TFTP....* gnu/bootloader/grub.scm (eye-candy)(font-file): Fix unicode font loading when booting over TFTP. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Stefan 2020-11-17bootloader: grub: Skip install-grub-efi when producing a disk image....Fixes <http://issues.guix.gnu.org/44353>. Every bootloader should try their best to install themselves using only the MOUNT-POINT and otherwise do nothing. This requirement comes from the necessity to call INSTALL-GRUB when installing the (non-EFI) GRUB bootloader, which needs to populate the root file system with extra modules that cannot be fit in the core.img file, limited in size to 491520 bytes (by the i386-pc format required for legacy BIOS compatibility). As introducing bootloader knowledge at the level of the image code is undesirable, every bootloader should be adapted to support this fall-back for their installation procedure (TODO). * gnu/bootloader/grub.scm (install-grub-efi)[efi-dir]: Skip when the EFI-DIR argument is set to #f. Maxim Cournoyer