aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/databases.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/databases.scm')
-rw-r--r--gnu/packages/databases.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/databases.scm b/gnu/packages/databases.scm
index 46f9f70e92..1f88524db3 100644
--- a/gnu/packages/databases.scm
+++ b/gnu/packages/databases.scm
@@ -1068,16 +1068,16 @@ developed in C/C++ to MariaDB and MySQL databases.")
(define-public galera
(package
(name "galera")
- (version "26.4.7")
+ (version "26.4.10")
(source (origin
(method git-fetch)
(uri (git-reference
- (commit "bac8171266cb982fe013ce496d78085438c6f23e")
(url "https://github.com/codership/galera")
+ (commit (string-append "release_" version))
(recursive? #t)))
(file-name (git-file-name name version))
(sha256
- (base32 "0h7s670pcasq8wzprhyxqfca2cghi62b8xz2kikb2a86wd453qil"))))
+ (base32 "1n6zhzwj713ixyqvcjn4ldlq0y9fxqgvmqv3cj3h4207v9lwlxxz"))))
(build-system cmake-build-system)
(inputs
(list check boost openssl))
a href='/guix/tree/gnu/local.mk?id=d9b8cfd6c649fb246f7fdf2dc283c27c4afae100'>gnu/local.mk
+++ b/gnu/local.mk
@@ -870,6 +870,7 @@ dist_patch_DATA = \
%D%/packages/patches/avidemux-install-to-lib.patch \
%D%/packages/patches/awesome-reproducible-png.patch \
%D%/packages/patches/aws-c-cal-cmake-prefix.patch \
+ %D%/packages/patches/aws-c-compression-cmake-prefix.patch \
%D%/packages/patches/aws-c-event-stream-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-cmake-prefix.patch \
%D%/packages/patches/aws-c-http-disable-networking-tests.patch\
diff --git a/gnu/packages/c.scm b/gnu/packages/c.scm
index 4490d391e6..8e0f97881c 100644
--- a/gnu/packages/c.scm
+++ b/gnu/packages/c.scm
@@ -743,3 +743,30 @@ low level functionality for coroutines.")
specifications.")
(home-page "https://github.com/awslabs/aws-c-http")
(license license:asl2.0)))
+
+(define-public aws-c-compression
+ (package
+ (name "aws-c-compression")
+ (version "0.2.13")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url (string-append "https://github.com/awslabs/" name))
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0zqfxi0fdgapfsfgvsindv63pq7vyl1s376qkpv4jgflyb1v6gp5"))
+ (patches (search-patches "aws-c-compression-cmake-prefix.patch"))))
+ (build-system cmake-build-system)
+ (arguments
+ '(#:configure-flags
+ '("-DBUILD_SHARED_LIBS=ON")))
+ (propagated-inputs
+ `(("aws-c-common" ,aws-c-common)))
+ (synopsis "Amazon Web Services compression library")
+ (description
+ "This library provides a C99 implementation of compression algorithms,
+currently limited to Huffman encoding and decoding.")
+ (home-page "https://github.com/awslabs/aws-c-compression")
+ (license license:asl2.0)))
diff --git a/gnu/packages/patches/aws-c-compression-cmake-prefix.patch b/gnu/packages/patches/aws-c-compression-cmake-prefix.patch
new file mode 100644
index 0000000000..eefae19c4a
--- /dev/null
+++ b/gnu/packages/patches/aws-c-compression-cmake-prefix.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -5,6 +5,10 @@ if (POLICY CMP0069)
+ cmake_policy(SET CMP0069 NEW) # Enable LTO/IPO if available in the compiler, see AwsCFlags
+ endif()
+
++if (DEFINED ENV{CMAKE_PREFIX_PATH})
++ set(CMAKE_PREFIX_PATH $ENV{CMAKE_PREFIX_PATH})
++endif()
++
+ if (DEFINED CMAKE_PREFIX_PATH)
+ file(TO_CMAKE_PATH "${CMAKE_PREFIX_PATH}" CMAKE_PREFIX_PATH)
+ endif()