aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-windows.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-windows.scm')
-rw-r--r--gnu/packages/crates-windows.scm33
1 files changed, 24 insertions, 9 deletions
diff --git a/gnu/packages/crates-windows.scm b/gnu/packages/crates-windows.scm
index 7e9c4623a5..bda7697c93 100644
--- a/gnu/packages/crates-windows.scm
+++ b/gnu/packages/crates-windows.scm
@@ -2160,8 +2160,31 @@ crate.")
(sha256
(base32 "03h0c6qs1yyl0z69p4k1hdq636j868qdxnri1dy47nprjvckacbm"))))))
+(define-public rust-windows-sys-0.59
+ (package
+ (name "rust-windows-sys")
+ (version "0.59.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "windows-sys" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fw5672ziw8b3zpmnbp9pdv1famk74f1l9fcbc3zsrzdg56vqf0y"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs (("rust-windows-targets" ,rust-windows-targets-0.52))))
+ (home-page "https://github.com/microsoft/windows-rs")
+ (synopsis "Rust for Windows")
+ (description "The windows crate lets you call any Windows API past,
+present, and future using code generated on the fly directly from the metadata
+describing the API and right into your Rust package where you can call them as
+if they were just another Rust module.")
+ (license (list license:expat license:asl2.0))))
+
(define-public rust-windows-sys-0.52
(package
+ (inherit rust-windows-sys-0.59)
(name "rust-windows-sys")
(version "0.52.0")
(source (origin
@@ -2171,17 +2194,9 @@ crate.")
(sha256
(base32
"0gd3v4ji88490zgb6b5mq5zgbvwv7zx1ibn8v3x83rwcdbryaar8"))))
- (build-system cargo-build-system)
(arguments
`(#:skip-build? #t
- #:cargo-inputs (("rust-windows-targets" ,rust-windows-targets-0.52))))
- (home-page "https://github.com/microsoft/windows-rs")
- (synopsis "Rust for Windows")
- (description "The windows crate lets you call any Windows API past,
-present, and future using code generated on the fly directly from the metadata
-describing the API and right into your Rust package where you can call them as
-if they were just another Rust module.")
- (license (list license:expat license:asl2.0))))
+ #:cargo-inputs (("rust-windows-targets" ,rust-windows-targets-0.52))))))
(define-public rust-windows-sys-0.48
(package