aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-io.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-io.scm')
-rw-r--r--gnu/packages/crates-io.scm21
1 files changed, 21 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 45966389dd..d017ee6216 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -28,6 +28,27 @@
;;; Please: Try to add new module packages in alphabetic order.
;;;
+(define-public rust-antidote
+ (package
+ (name "rust-antidote")
+ (version "1.0.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "antidote" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "19g2sw2qa2ibnh4x7j1snk46593jgx6y7rnvva496ynq61af5z9l"))))
+ (build-system cargo-build-system)
+ (home-page "https://github.com/sfackler/rust-antidote")
+ (synopsis "Poison-free Mutex and RwLock types")
+ (description
+ "These types expose identical APIs to the standard library @code{Mutex} and
+@code{RwLock} except that they do not return @code{PoisonError}s.")
+ (license (list license:asl2.0
+ license:expat))))
+
(define-public rust-autocfg
(package
(name "rust-autocfg")