aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/crates-apple.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/crates-apple.scm')
-rw-r--r--gnu/packages/crates-apple.scm35
1 files changed, 35 insertions, 0 deletions
diff --git a/gnu/packages/crates-apple.scm b/gnu/packages/crates-apple.scm
index 7e4d1ee543..c9032bfac2 100644
--- a/gnu/packages/crates-apple.scm
+++ b/gnu/packages/crates-apple.scm
@@ -365,3 +365,38 @@ extension of blocks.")
("rust-core-graphics" ,rust-core-graphics-0.22)
("rust-foreign-types" ,rust-foreign-types-0.3)
("rust-libc" ,rust-libc-0.2))))))
+
+(define-public rust-dispatch-0.2
+ (package
+ (name "rust-dispatch")
+ (version "0.2.0")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dispatch" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0fwjr9b7582ic5689zxj8lf7zl94iklhlns3yivrnv8c9fxr635x"))))
+ (build-system cargo-build-system)
+ (arguments `(#:skip-build? #t))
+ (home-page "https://github.com/SSheldon/rust-dispatch")
+ (synopsis "Rust wrapper for Apple's Grand Central Dispatch")
+ (description "This package provides a Rust wrapper for Apple's Grand
+Central Dispatch.")
+ (license license:expat)))
+
+(define-public rust-dispatch-0.1
+ (package
+ (inherit rust-dispatch-0.2)
+ (name "rust-dispatch")
+ (version "0.1.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "dispatch" version))
+ (file-name
+ (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "019nzy993hxaiazcdnayx3csv2iki34i535asw11ki96hakkrs84"))))
+ (arguments '(#:tests? #f)))) ; Tests only run on Mac.