aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm20
1 files changed, 20 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 8200ccfafa..9e50eed3cd 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -689,3 +689,23 @@ diagnostic checking in linear regression models. Furthermore, some generic
tools for inference in parametric models are provided.")
;; Either version is okay
(license (list license:gpl2 license:gpl3))))
+
+(define-public r-inline
+ (package
+ (name "r-inline")
+ (version "0.3.14")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "inline" version))
+ (sha256
+ (base32
+ "0cf9vya9h4znwgp6s1nayqqmh6mwyw7jl0isk1nx4j2ijszxcd7x"))))
+ (build-system r-build-system)
+ (home-page "http://cran.r-project.org/web/packages/inline")
+ (synopsis "Functions to inline C, C++, Fortran function calls from R")
+ (description
+ "This package provides functionality to dynamically define R functions
+and S4 methods with inlined C, C++ or Fortran code supporting @code{.C} and
+@code{.Call} calling conventions.")
+ ;; Any version of the LGPL.
+ (license license:lgpl3+)))
> 2020-03-17bootloader: grub: Refactor eye-candy a bit....Maxim Cournoyer 2020-03-17bootloader: grub: Use the all_video module in graphic mode....Maxim Cournoyer 2020-02-02gnu: Add u-boot-cubietruck-bootloader....Julien Lepiller 2020-01-25bootloader: grub: Add gfxmode (resolution) override....Jan Nieuwenhuizen 2020-01-07Revert "bootloader: grub: Add gfxmode (resolution) override."...Tobias Geerinckx-Rice 2020-01-07bootloader: grub: Add gfxmode (resolution) override....Jan Nieuwenhuizen 2020-01-06Adjust module autoloads....Ludovic Courtès 2020-01-03bootloader: Mark "grub.cfg" and "extlinux.conf" as non-substitutable....Ludovic Courtès 2019-12-23bootloader: grub: Add firmware setup entry....Brice Waegeneire 2019-12-14gnu: Add u-boot-pine64-lts-bootloader....Mathieu Othacehe 2019-10-18gnu: Add u-boot-firefly-rk3399....Vagrant Cascadian 2019-10-18gnu: Add u-boot-rock64-rk3328....Vagrant Cascadian 2019-10-18gnu: Add u-boot-rockpro64-rk3399...Caliph Nomble 2019-05-09bootloader: grub: Remove unneeded 'terminal_output'....Ludovic Courtès 2019-04-29gnu: u-boot: Update to 2019.04....Vagrant Cascadian 2019-04-03gnu: Add configuration for depthcharge bootloader....Timothy Sample 2019-03-24bootloader: Add a 'keyboard-layout' field....Ludovic Courtès 2019-03-16bootloader: Use 'invoke/quiet' when running 'grub-install' and co....Ludovic Courtès 2019-03-13Remove traces of "GuixSD"....Ludovic Courtès 2018-11-22gnu: Add u-boot-pinebook....Vagrant Cascadian 2018-11-18bootloader: De-monadify configuration file generators....Ludovic Courtès 2018-09-14gnu: Rename "banana-pi" to "bananapi"....Danny Milosavljevic