aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/cran.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/cran.scm')
-rw-r--r--gnu/packages/cran.scm279
1 files changed, 167 insertions, 112 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index dbbf30c551..a688aacd9e 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -1344,13 +1344,13 @@ compositional data.")
(define-public r-gwasexacthw
(package
(name "r-gwasexacthw")
- (version "1.01")
+ (version "1.2")
(source (origin
(method url-fetch)
(uri (cran-uri "GWASExactHW" version))
(sha256
(base32
- "19qmk8h7kxmn9kzw0x4xns5p3qqz27xkqq4q6zmh4jzizd0fsl78"))))
+ "1xzcvmbh27ibd7g9zlqyp215q4yfkhdypcvm5gjkvw1qhd3pl4yk"))))
(properties `((upstream-name . "GWASExactHW")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/package=GWASExactHW")
@@ -2318,13 +2318,13 @@ known as Dynamic Linear Models.")
(define-public r-zcompositions
(package
(name "r-zcompositions")
- (version "1.5.0-1")
+ (version "1.5.0-3")
(source (origin
(method url-fetch)
(uri (cran-uri "zCompositions" version))
(sha256
(base32
- "0sx6i03iyg4jxmjiyzkssz3i6c8nv29wwhbl7yd0wxapwpakmlj8"))))
+ "1gbwx3vgx5viqnn5jsszild6ikyc2pmf1hdjc9475caf9xx9l589"))))
(properties `((upstream-name . "zCompositions")))
(build-system r-build-system)
(propagated-inputs
@@ -3841,6 +3841,30 @@ algorithm described in MetaCell analysis of single-cell RNA-seq
data using K-nn graph partitions.")
(license license:gpl2)))
+(define-public r-tictoc
+ (package
+ (name "r-tictoc")
+ (version "1.2.1")
+ (source (origin
+ (method url-fetch)
+ (uri (cran-uri "tictoc" version))
+ (sha256
+ (base32
+ "0cw8r1gn4p2v1l3d80brk9sfr9nyckyyym5nr9xq3d74l74vgkcg"))))
+ (properties `((upstream-name . "tictoc")))
+ (build-system r-build-system)
+ (home-page "https://github.com/jabiru/tictoc")
+ (synopsis
+ "Time R scripts and implementations of stack and list structures")
+ (description
+ "The tictoc package provides the timing functions @code{tic} and
+@code{toc} that can be nested. It provides an alternative to
+@code{system.time()} with a different syntax similar to that in another
+well-known software package. @code{tic} and @code{toc} are easy to use, and
+are especially useful when timing several sections in more than a few lines of
+code.")
+ (license license:asl2.0)))
+
(define-public r-tidyft
(package
(name "r-tidyft")
@@ -4998,14 +5022,14 @@ weights.")
(define-public r-sass
(package
(name "r-sass")
- (version "0.4.8")
+ (version "0.4.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "sass" version))
(sha256
(base32
- "0364ndnmlqrga3k4c1hfy1894k5wpm9srf9201g9zb92rlq2kfj2"))))
+ "1lnl2xssz33vg7p6a8ij55hg6j1p1d3y2mq22pvf0r3rmnd08cz1"))))
(properties `((upstream-name . "sass")))
(build-system r-build-system)
(propagated-inputs
@@ -6515,13 +6539,13 @@ processes. Most of its code is based on the @code{psutil} Python package.")
(define-public r-pkgbuild
(package
(name "r-pkgbuild")
- (version "1.4.3")
+ (version "1.4.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "pkgbuild" version))
(sha256
- (base32 "0rci20gj2x0bgjy51jp8i4gld6arsigj7lhdkpwvdyhadjsyv0qm"))))
+ (base32 "1a72s2gg7ddjj94naiii44f3vyhky05gaa6xvdf72m1nshy88wjr"))))
(build-system r-build-system)
(propagated-inputs
(list r-callr r-cli r-desc r-processx r-r6))
@@ -8945,14 +8969,14 @@ problems as well as resampling based estimators of prediction error.")
(define-public r-psych
(package
(name "r-psych")
- (version "2.4.1")
+ (version "2.4.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "psych" version))
(sha256
(base32
- "08ip2m91c6hinva18zv575cn6w14pnjc503m1gisrg65c3z3f69b"))))
+ "0ic479y314knn20m1cjlp15lji7f70xrg95ln570pgkhrk5853bi"))))
(build-system r-build-system)
(propagated-inputs
(list r-lattice r-mnormt r-nlme))
@@ -9132,13 +9156,13 @@ from the data points.")
(define-public r-coro
(package
(name "r-coro")
- (version "1.0.3")
+ (version "1.0.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "coro" version))
(sha256
- (base32 "0wvxdpdh3xrskz5s5wfkva856x849knx1jigbf0ff6s6n6qjjxsf"))))
+ (base32 "0r6cb2gr29vxjlbfzqxdgbccp57l6raxncljisl1vyj6xi2by8cg"))))
(properties `((upstream-name . "coro")))
(build-system r-build-system)
(propagated-inputs (list r-rlang))
@@ -10277,13 +10301,13 @@ constants, and control debugging of packages via environment variables.")
(define-public r-processx
(package
(name "r-processx")
- (version "3.8.3")
+ (version "3.8.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "processx" version))
(sha256
- (base32 "0cfq6pq8rg0vhjfgvf48hfvngbn1g6hv28b6pgxh55xqh8acbn0s"))))
+ (base32 "02z7n59pglz6jw1vyyl0mkc7mz2c7y8yzsnhq5yz62digwnnf9v6"))))
(build-system r-build-system)
(propagated-inputs
(list r-ps r-r6))
@@ -10712,14 +10736,14 @@ vectors.")
(define-public r-tinytex
(package
(name "r-tinytex")
- (version "0.49")
+ (version "0.50")
(source
(origin
(method url-fetch)
(uri (cran-uri "tinytex" version))
(sha256
(base32
- "0i9icscy5n6p6w3f4v2z3cznywrrv2l6xyyhb0k1fpa4cpn6j4cl"))))
+ "11k0pl073b4k4wmpxkw4a071jbpvhr1g3cwm9v99rw3gh6p6x15l"))))
(build-system r-build-system)
(propagated-inputs
(list r-xfun))
@@ -10797,13 +10821,13 @@ implementation of an approximate nearest neighbor search using hierarchical
(define-public r-nestedcv
(package
(name "r-nestedcv")
- (version "0.7.4")
+ (version "0.7.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "nestedcv" version))
(sha256
- (base32 "0ymy1dbkcpiyq44zpvpkz1m5ivnchip07q6agh6ij50imddxb48s"))))
+ (base32 "1pdky7kzqs1rhl0f4hba3sggifplfgbp339imxym4dvvdb81b589"))))
(properties `((upstream-name . "nestedcv")))
(build-system r-build-system)
(propagated-inputs (list r-caret
@@ -10812,13 +10836,13 @@ implementation of an approximate nearest neighbor search using hierarchical
r-foreach
r-ggplot2
r-glmnet
- r-magrittr
r-matrixstats
r-matrixtests
r-proc
r-rfast
r-rhpcblasctl
- r-rlang))
+ r-rlang
+ r-rocr))
(native-inputs (list r-knitr))
(home-page "https://github.com/myles-lewis/nestedcv")
(synopsis "Nested cross-validation with glmnet and caret")
@@ -12593,6 +12617,45 @@ contain lags, diffs and missing values.")
;; Any GPL version.
(license license:gpl2+)))
+(define-public r-dyngen
+ (package
+ (name "r-dyngen")
+ (version "1.0.5")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "dyngen" version))
+ (sha256
+ (base32
+ "095jqn1rd83qm3ayca9hmv6bhlaa2c338020l46vniq8n38kbnra"))))
+ (properties `((upstream-name . "dyngen")))
+ (build-system r-build-system)
+ (propagated-inputs
+ (list r-assertthat
+ r-dplyr
+ r-dynutils
+ r-ggplot2
+ r-ggraph
+ r-ggrepel
+ r-gillespiessa2
+ r-igraph
+ r-lmds
+ r-matrix
+ r-patchwork
+ r-pbapply
+ r-purrr
+ r-rlang
+ r-tibble
+ r-tidygraph
+ r-tidyr
+ r-viridis))
+ (home-page "https://github.com/dynverse/dyngen")
+ (synopsis "Multi-Modal simulator for single-cell omics analyses")
+ (description
+ "This package provides a multi-modal simulation engine for studying
+dynamic cellular processes at single-cell resolution.")
+ (license license:expat)))
+
(define-public r-dynutils
(package
(name "r-dynutils")
@@ -13709,14 +13772,14 @@ Sequence logos can easily be combined with other ggplot2 plots.")
(define-public r-ggsci
(package
(name "r-ggsci")
- (version "3.0.1")
+ (version "3.0.2")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggsci" version))
(sha256
(base32
- "030rkjx64mlhy19d74p3blsi92nyjq9vbn33323dvm1rihb8avgi"))))
+ "0qasxv3aliqqmfi3nk3140lrbcrw4lbfw5hm65hfkgf5a3bkca67"))))
(build-system r-build-system)
(propagated-inputs
(list r-ggplot2 r-scales))
@@ -14486,14 +14549,14 @@ Decomposition in R (Beaton et al 2014) <doi:10.1016/j.csda.2013.11.006>.")
(define-public r-insight
(package
(name "r-insight")
- (version "0.19.8")
+ (version "0.19.9")
(source
(origin
(method url-fetch)
(uri (cran-uri "insight" version))
(sha256
(base32
- "1f76fqrcv54l01z2nb46ysh3f41j06nqpn4ffn2gmjfggmj4xvwq"))))
+ "0q6wd28bnav9vwzprwvm9fhpmhqvq85iyg4h503lavcvi5g39a9x"))))
(build-system r-build-system)
(native-inputs
(list r-knitr))
@@ -14572,13 +14635,13 @@ tidyverse workflow.")
(define-public r-nodbi
(package
(name "r-nodbi")
- (version "0.10.3")
+ (version "0.10.4")
(source (origin
(method url-fetch)
(uri (cran-uri "nodbi" version))
(sha256
(base32
- "17ghgp6sabj4dlmx3cdn9rrhci7050a73cd17fymjksgvy1jbwf6"))))
+ "0q4nsxic1jlraipdc6zi711c3316n9wgq1cgbywhjlxb52qhkmd7"))))
(properties `((upstream-name . "nodbi")))
(build-system r-build-system)
(propagated-inputs
@@ -14652,14 +14715,14 @@ functions.")
(define-public r-flextable
(package
(name "r-flextable")
- (version "0.9.4")
+ (version "0.9.5")
(source
(origin
(method url-fetch)
(uri (cran-uri "flextable" version))
(sha256
(base32
- "1dlsag1y3s7d5lp1dh2kxf1qax4r9xvxycpmxl64gkr50dk13bam"))))
+ "14mq27k7998405qwpdpxa1csbf5pdgzj9s892xm95bd4chnshdvw"))))
(build-system r-build-system)
(propagated-inputs
(list r-data-table
@@ -14730,13 +14793,13 @@ contains or can be specified by the user.")
(define-public r-wrs2
(package
(name "r-wrs2")
- (version "1.1-5")
+ (version "1.1-6")
(source (origin
(method url-fetch)
(uri (cran-uri "WRS2" version))
(sha256
(base32
- "028xs424m879siaf3rrhzl1dacp9j7wcl5fpikyx2n0cc7anq4vq"))))
+ "1wsnsl4gy1hbgxfzzhfybak0jqmxq9fsh3scqyxydd7ia9r2n52k"))))
(properties `((upstream-name . "WRS2")))
(build-system r-build-system)
(propagated-inputs (list r-mass r-plyr r-reshape))
@@ -16525,14 +16588,14 @@ console, resulting in an interactive editing environment.")
(define-public r-survey
(package
(name "r-survey")
- (version "4.2-1")
+ (version "4.4-1")
(source
(origin
(method url-fetch)
(uri (cran-uri "survey" version))
(sha256
(base32
- "0l7iml53k2blmcgvbvplln08fn2s6da856m5izcvw87v6bhn2g6c"))))
+ "1649srmdr8i9j8grqikkm8nbfav31s7iygx6pv96jvr3wh80yh46"))))
(build-system r-build-system)
(propagated-inputs
(list r-lattice
@@ -16540,7 +16603,10 @@ console, resulting in an interactive editing environment.")
r-minqa
r-mitools
r-numderiv
+ r-rcpp
+ r-rcpparmadillo
r-survival))
+ (native-inputs (list r-r-rsp))
(home-page "https://r-survey.r-forge.r-project.org/survey/")
(synopsis "Analysis of complex survey samples")
(description
@@ -16607,13 +16673,13 @@ handle data from simple random samples as well as complex surveys.")
(define-public r-tarchetypes
(package
(name "r-tarchetypes")
- (version "0.7.12")
+ (version "0.8.0")
(source (origin
(method url-fetch)
(uri (cran-uri "tarchetypes" version))
(sha256
(base32
- "0l5kk7a3p0pbqh9rrjz43aa4dgcfffcb3wwsl60bm9v48lzv7frv"))))
+ "18vn2mx5nqlib0by5v7493g8gsbzcdbg0dn92cpbf713r69v1lbk"))))
(properties `((upstream-name . "tarchetypes")))
(build-system r-build-system)
(propagated-inputs (list r-digest
@@ -16641,13 +16707,13 @@ were influenced by the drake R package by Will Landau (2018)
(define-public r-targets
(package
(name "r-targets")
- (version "1.5.1")
+ (version "1.6.0")
(source (origin
(method url-fetch)
(uri (cran-uri "targets" version))
(sha256
(base32
- "1g21cp0p5jdghr61w9q3y73jm2k248z4apn7rlxqm6m18i4x7zsb"))))
+ "1ddpbhvdydxm62k6ay7hpqjh8kh2isjpcdh3gygzcdrghx6d7x65"))))
(properties `((upstream-name . "targets")))
(build-system r-build-system)
(propagated-inputs (list r-base64url
@@ -17065,13 +17131,13 @@ Hothorn, Westfall, 2010, CRC Press).")
(define-public r-multcompview
(package
(name "r-multcompview")
- (version "0.1-9")
+ (version "0.1-10")
(source
(origin
(method url-fetch)
(uri (cran-uri "multcompView" version))
(sha256
- (base32 "15vki166n2k4ng72hy62c2mzz18s10h6l6w839qplg0zsplr6f8z"))))
+ (base32 "12mdk12xciq1d3zn94rixahhcah2qq41lvb5n4kzgjaq4yr4kwiq"))))
(properties `((upstream-name . "multcompView")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/package=multcompView")
@@ -17780,14 +17846,14 @@ more information about packages, and where they were installed from.")
(define-public r-remotes
(package
(name "r-remotes")
- (version "2.4.2.1")
+ (version "2.5.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "remotes" version))
(sha256
(base32
- "1790q52z4fy4zb1hnpn066q9fph53syl7gaxlbgbqq1dcndcma3v"))))
+ "0345s9q0fyv0wrxkklcy97h7bi85jfb3vwkh80px926d4qa3yrjd"))))
(build-system r-build-system)
(native-inputs
(list r-knitr))
@@ -18529,14 +18595,14 @@ Bioconductor packages.")
(define-public r-rgl
(package
(name "r-rgl")
- (version "1.2.8")
+ (version "1.3.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "rgl" version))
(sha256
(base32
- "1x0p2yldg2mjf64xd5dd0bidzgy7b39w7zn18ghan2rdf0wffdg5"))
+ "0jbda1b4lrkcpdld369687pm7isy69l5sx1wg2yrpvvzvmcppslz"))
(snippet
'(delete-file "inst/htmlwidgets/lib/CanvasMatrix/CanvasMatrix.min.js"))))
;; For OpenGL and X11 support
@@ -18561,10 +18627,10 @@ Bioconductor packages.")
r-rmarkdown)) ;for vignettes
(inputs
(list freetype
- libpng
glu
+ libpng
libx11
- pandoc
+ zlib
zlib))
(propagated-inputs
(list r-base64enc
@@ -18978,13 +19044,13 @@ Tabelow (2007) <DOI:10.18637/jss.v019.i01>.")
(define-public r-admisc
(package
(name "r-admisc")
- (version "0.34")
+ (version "0.35")
(source
(origin
(method url-fetch)
(uri (cran-uri "admisc" version))
(sha256
- (base32 "1psvi8hb7j65abw8g4ya9r43r5kd9mcv478pg2d09za0cig8gkzx"))))
+ (base32 "0gzdb9dm34qfkjqgfrd3wm96dzhcps4xayyrhp80mzgh14zmnjyg"))))
(properties `((upstream-name . "admisc")))
(build-system r-build-system)
(home-page "https://github.com/dusadrian/admisc")
@@ -19198,14 +19264,14 @@ Processing.")
(define-public r-tm
(package
(name "r-tm")
- (version "0.7-11")
+ (version "0.7-12")
(source
(origin
(method url-fetch)
(uri (cran-uri "tm" version))
(sha256
(base32
- "0hp7xamjmifd56qwsin5m0xng592wwxsbfxdz37n4k6zjf28paws"))))
+ "1z0zpz6jgzg34cz07cdpya2zwwsvywrd8xgwahhlz15vnaij7j3y"))))
(properties `((upstream-name . "tm")))
(build-system r-build-system)
(propagated-inputs
@@ -19327,14 +19393,14 @@ over-plotting in scatter plots with text.")
(define-public r-colorramps
(package
(name "r-colorramps")
- (version "2.3.2")
+ (version "2.3.4")
(source
(origin
(method url-fetch)
(uri (cran-uri "colorRamps" version))
(sha256
(base32
- "0cq8l6ybhff2q2dj2i73b4cnw6v2c6ql24jbrkh0xrpc9wjsarxj"))))
+ "1y4gn6v8wmwq3wcfgdnx1ah2qa53gayvbfa62kp286ga4c8k3prw"))))
(properties `((upstream-name . "colorRamps")))
(build-system r-build-system)
(home-page "https://cran.r-project.org/web/packages/colorRamps")
@@ -19931,14 +19997,14 @@ and compatibility with @code{ape} objects.")
(define-public r-rnifti
(package
(name "r-rnifti")
- (version "1.6.0")
+ (version "1.6.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "RNifti" version))
(sha256
(base32
- "0spsdkqvlkk7xn6wz6778gc6cc7dnfcwpz91q8wdzxgcbgxdy0yv"))))
+ "0wn06fnq5c7f0vwakryb75vzkjh03dqz2z57lgmn68hwgssnpalc"))))
(properties `((upstream-name . "RNifti")))
(build-system r-build-system)
(inputs (list zlib))
@@ -20429,14 +20495,14 @@ preparing, executing, and processing HTTP requests.")
(define-public r-bigrquery
(package
(name "r-bigrquery")
- (version "1.5.0")
+ (version "1.5.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "bigrquery" version))
(sha256
(base32
- "1s2vvygv4d8mdd67r6j2s9d1xg009lpxysfarmrnqh0s2s1rglkz"))))
+ "0wkm9xka83skq1cnv830q4jnqvwm8rlmns2mj8n692h2y5qxlmna"))))
(build-system r-build-system)
(propagated-inputs
(list r-bit64
@@ -21642,14 +21708,14 @@ subsetting.")
(define-public r-globals
(package
(name "r-globals")
- (version "0.16.2")
+ (version "0.16.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "globals" version))
(sha256
(base32
- "02kpdlrx1bannaixz03c0f7bii9g36iy2nw779mfgi56byljcb38"))))
+ "0nwcl40sbmmf812di9c3lryls9wn2k2dyjvpkp9832wd4jafsg6p"))))
(build-system r-build-system)
(propagated-inputs
(list r-codetools))
@@ -22208,14 +22274,14 @@ numbers (e.g. concentrations).")
(define-public r-cobs
(package
(name "r-cobs")
- (version "1.3-7")
+ (version "1.3-8")
(source
(origin
(method url-fetch)
(uri (cran-uri "cobs" version))
(sha256
(base32
- "0gz6i8scvfkmg0z7rcqc422dm360xv5ygcxnj6yyvpcpdv7sdp9k"))))
+ "08cqpiylbfy5j5xxajpngqaycmmciwhyf3sk3972x2l6rg3lj81c"))))
(build-system r-build-system)
(propagated-inputs
(list r-quantreg r-sparsem))
@@ -22798,14 +22864,14 @@ network.")
(define-public r-gmodels
(package
(name "r-gmodels")
- (version "2.18.1.1")
+ (version "2.19.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "gmodels" version))
(sha256
(base32
- "158y7yh4maawn9vki8cq4sil48xib2bbpl6qgj5gvlkw3c14hzfs"))))
+ "13c8x7iwyz36qir3ikbvjb5dl6gdh4fh82qdxcpcdinwfhrbhmxv"))))
(build-system r-build-system)
(propagated-inputs
(list r-gdata r-mass))
@@ -23727,13 +23793,13 @@ lspec, polyclass, and polymars.")
(define-public r-rms
(package
(name "r-rms")
- (version "6.7-1")
+ (version "6.8-0")
(source
(origin
(method url-fetch)
(uri (cran-uri "rms" version))
(sha256
- (base32 "199xb98zxsbd8wa9g33bgrvbcpq79glnfmq060ic8f9vjw96r0qz"))))
+ (base32 "1cd6m6i2ild2f2x9rkyd2aqb33q3xy0596bs3dnvr2mnh5fcar5d"))))
(build-system r-build-system)
(propagated-inputs
(list r-cluster
@@ -24829,14 +24895,14 @@ databases, including ENA, PDB or ChEMBL are also accessible.")
(define-public r-ggraph
(package
(name "r-ggraph")
- (version "2.2.0")
+ (version "2.2.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "ggraph" version))
(sha256
(base32
- "0zs02xyzvimk8hj1z465zxp1hlca3gfirdcwb3gqriwsmnfhg661"))))
+ "1w9snb43wpa2rv16fx5vmh7nqpgkr05iz6flnmlfx3xd0ylzh1a4"))))
(build-system r-build-system)
(propagated-inputs
(list r-cli
@@ -25631,14 +25697,14 @@ colored by the number of neighboring points. This is useful to visualize the
(define-public r-arrow
(package
(name "r-arrow")
- (version "14.0.2.1")
+ (version "15.0.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "arrow" version))
(sha256
(base32
- "1l1ninmq6mbqm7cckcy0qw4f20fkrixrykcqkh24bszg514r9af5"))))
+ "070pp0p5h1ij7pg34l5grrx4vwfihagnvnk4kj7l3w0gh8y88ibz"))))
(properties `((upstream-name . "arrow")))
(build-system r-build-system)
(inputs
@@ -27262,14 +27328,14 @@ both R code and compiled C/C++/FORTRAN code.")
(define-public r-systemfonts
(package
(name "r-systemfonts")
- (version "1.0.5")
+ (version "1.0.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "systemfonts" version))
(sha256
(base32
- "08sqw5izpwhawcjkcyscvslz914skwfi0s68rdwrqwwkh8fzn3w4"))))
+ "1mqxb2njfnk5rfwkqc940xbpwd3dh25zac4sapv5mjyddrxnwn6i"))))
(properties `((upstream-name . "systemfonts")))
(build-system r-build-system)
(propagated-inputs
@@ -27291,14 +27357,14 @@ be used further by e.g. graphic devices.")
(define-public r-graphlayouts
(package
(name "r-graphlayouts")
- (version "1.1.0")
+ (version "1.1.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "graphlayouts" version))
(sha256
(base32
- "14ib4yjcxb6zgci5h89p9swqabab57bzywwp96d3nhn620chap22"))))
+ "009q5y46lbizdabbb6a61xlfa3g5lf3nd9w42709lcxi0ad4bhkv"))))
(properties `((upstream-name . "graphlayouts")))
(build-system r-build-system)
(propagated-inputs
@@ -27443,14 +27509,14 @@ in pipelines.")
(define-public r-parameters
(package
(name "r-parameters")
- (version "0.21.5")
+ (version "0.21.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "parameters" version))
(sha256
(base32
- "0yxljycspmljj5s4i5knwyhxp29s616f7kg3xcwn0ip15kfg260v"))))
+ "004ld3m9qdq3bwl8qmp3h700kzqlgbmgz739d7fpiqgrs0s2gv83"))))
(properties `((upstream-name . "parameters")))
(build-system r-build-system)
(propagated-inputs
@@ -28550,21 +28616,18 @@ and mixture of Gaussian models.")
(define-public r-accsda
(package
(name "r-accsda")
- (version "1.1.2")
+ (version "1.1.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "accSDA" version))
(sha256
(base32
- "0jf4x5j9y7a3mvf2ghjp6bxdq1s5jh2sx3x3ar6f3lyzzvrnls4v"))))
+ "1s0c4wy4bzrc2fkka7kl519z1yckp6s4ggzy1ik992ygyprdcs1q"))))
(properties `((upstream-name . "accSDA")))
(build-system r-build-system)
(propagated-inputs
- (list r-ggplot2
- r-ggthemes
- r-gridextra
- r-mass))
+ (list r-ggplot2 r-gridextra r-mass))
(home-page "https://github.com/gumeo/accSDA/wiki")
(synopsis "Accelerated sparse discriminant analysis")
(description
@@ -28790,14 +28853,14 @@ discussed in Reisen et al. (2017) @url{doi:10.1016/j.jspi.2017.02.008}.")
(define-public r-gamlss-data
(package
(name "r-gamlss-data")
- (version "6.0-2")
+ (version "6.0-6")
(source
(origin
(method url-fetch)
(uri (cran-uri "gamlss.data" version))
(sha256
(base32
- "07mpdl4h9rwmnpl9jmsn6ig8ji11an6pyjfsvg62h2alapwbdcyv"))))
+ "08mb154mz1kk19zb414i5mg1q1yv7nylwpc5kzsb602mv4cxpq5s"))))
(properties `((upstream-name . "gamlss.data")))
(build-system r-build-system)
(home-page "http://www.gamlss.org/")
@@ -29856,14 +29919,14 @@ variable observed over time.")
(define-public r-fda
(package
(name "r-fda")
- (version "6.1.7")
+ (version "6.1.8")
(source
(origin
(method url-fetch)
(uri (cran-uri "fda" version))
(sha256
(base32
- "00hiz15v31zs5l0bqdkim1fpfd3bjvssv77iczq0si724s4fqxiq"))))
+ "01y488zviaj9z8h88vnia9wg4as62jx73la1qji1ljbr5258b3gg"))))
(properties `((upstream-name . "fda")))
(build-system r-build-system)
(propagated-inputs
@@ -31470,7 +31533,7 @@ pages.")
"These utilities facilitate the programmatic manipulations of formulas,
expressions, calls, assignments and other R language objects. These objects
all share the same structure: a left-hand side, operator and right-hand side.
-This packages provides methods for accessing and modifying this structures as
+This package provides methods for accessing and modifying this structures as
well as extracting and replacing names and symbols from these objects.")
(license license:gpl2)))
@@ -32360,14 +32423,14 @@ Latent regression models and plausible value imputation are also supported.")
(define-public r-erm
(package
(name "r-erm")
- (version "1.0-5")
+ (version "1.0-6")
(source
(origin
(method url-fetch)
(uri (cran-uri "eRm" version))
(sha256
(base32
- "0bkivhiy02pibdcvb9z0i0yvc3wz3v33n6slhkkik61gcw1idmf0"))))
+ "059xny2jl81is1qyxgpbf4qi5zqpvdc64322kjz1i011kq9apwmw"))))
(properties `((upstream-name . "eRm")))
(build-system r-build-system)
(propagated-inputs
@@ -32714,14 +32777,14 @@ techniques to average Bayesian predictive distributions.")
(define-public r-rstan
(package
(name "r-rstan")
- (version "2.32.5")
+ (version "2.32.6")
(source
(origin
(method url-fetch)
(uri (cran-uri "rstan" version))
(sha256
(base32
- "0m655pf0lrhqh2mzylximd2vch9wy252k4zwyfqn1sfwmx642dva"))))
+ "0w0si8sd26c4nivqh85y0imil14sp4vy97yikmrv1lxvj40x141k"))))
(properties
'((upstream-name . "rstan")
(updater-extra-native-inputs . ("tzdata-for-tests"))))
@@ -32750,6 +32813,7 @@ techniques to average Bayesian predictive distributions.")
r-rcppeigen
r-rcppparallel
r-stanheaders))
+ (inputs (list pandoc))
(home-page "https://discourse.mc-stan.org/")
(synopsis "R interface to Stan")
(description
@@ -35663,14 +35727,14 @@ model.")
(define-public r-igraph
(package
(name "r-igraph")
- (version "2.0.2")
+ (version "2.0.3")
(source
(origin
(method url-fetch)
(uri (cran-uri "igraph" version))
(sha256
(base32
- "0kfc9blyy54cz0m4mdzzwgvn0rkil49kdk438411mx62g2vxby9l"))))
+ "0xlg5lxzr8dc260fii43chsspqvb962i1yrcars988b78lnig2lf"))))
(properties
`((upstream-name . "igraph")
(updater-extra-native-inputs . ("which"))))
@@ -35678,7 +35742,7 @@ model.")
(native-inputs
(list gfortran pkg-config r-knitr which))
(inputs
- (list glpk gmp libxml2 zlib))
+ (list glpk libxml2 zlib))
(propagated-inputs
(list r-cli
r-cpp11
@@ -36892,13 +36956,13 @@ other R users.")
(define-public r-seurat
(package
(name "r-seurat")
- (version "5.0.2")
+ (version "5.0.3")
(source (origin
(method url-fetch)
(uri (cran-uri "Seurat" version))
(sha256
(base32
- "1d49a9mhip81lvnkr8i4dznkmzyskdzrpi485w7yw2sr0qbyzg5c"))))
+ "08r5l6sk8i134izd29ydfm7hva7a9b3lfglmgngc9w73qs9dzwz4"))))
(properties `((upstream-name . "Seurat")))
(build-system r-build-system)
(propagated-inputs
@@ -37668,13 +37732,13 @@ computational operations, add-on packages provide additional functionality.")
(define-public r-mlr3learners
(package
(name "r-mlr3learners")
- (version "0.5.8")
+ (version "0.6.0")
(source (origin
(method url-fetch)
(uri (cran-uri "mlr3learners" version))
(sha256
(base32
- "0q44qmd9zfc68jl2zz684rx9744g83vd7z40dck8cdvnnrxcff5g"))))
+ "06gz6h19cnb62js1b35nddy453dyj64mr788p8ww56kgfk6yzxr8"))))
(build-system r-build-system)
(propagated-inputs
(list r-checkmate
@@ -38019,14 +38083,14 @@ the font tool-set provided by the @code{systemfonts} package.")
(define-public r-ragg
(package
(name "r-ragg")
- (version "1.2.7")
+ (version "1.3.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "ragg" version))
(sha256
(base32
- "17qc53scxf02f8hlpyirsjdav4wjh3mk6q04npf82y0j5mk1hynp"))))
+ "1chlas4i6p8gigx02x1y7nanmz9jbv1h4fa145zk223bbg9j931j"))))
(properties `((upstream-name . "ragg")))
(build-system r-build-system)
(inputs
@@ -39592,28 +39656,19 @@ package.")
(define-public r-qs
(package
(name "r-qs")
- (version "0.25.7")
+ (version "0.26.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "qs" version))
(sha256
(base32
- "0a0jay9p2k0ahf08s94dr1w66qhbgzs87vkaanwkd4j6lvijncz7"))))
+ "0qmgnc4igy8mjzarm30cgi4z75hh8f01kvcs6n6s63cy4qk30vs6"))))
(properties `((upstream-name . "qs")))
(build-system r-build-system)
- (arguments
- (list
- #:phases
- '(modify-phases %standard-phases
- ;; Our zstd is at 1.5.0, but this package bundles 1.5.2.
- (add-after 'unpack 'use-older-zstd
- (lambda _
- (substitute* "configure"
- (("100502") "100500")))))))
(inputs (list lz4 (list zstd "lib")))
(propagated-inputs
- (list r-rapiserialize r-rcpp r-stringfish))
+ (list r-bh r-rapiserialize r-rcpp r-stringfish))
(native-inputs
(list pkg-config r-knitr))
(home-page "https://github.com/traversc/qs")
@@ -40039,14 +40094,14 @@ fully reproducible.")
(define-public r-paws-common
(package
(name "r-paws-common")
- (version "0.7.0")
+ (version "0.7.1")
(source
(origin
(method url-fetch)
(uri (cran-uri "paws.common" version))
(sha256
(base32
- "05rld34brjc32p9f9cbqyyh208rh9idnyih33cpw7bz7bfyicnqm"))))
+ "1mjbyykav3f5yv59hnaihqsqhinvrlhphp93ks9xp756w6abciqf"))))
(properties `((upstream-name . "paws.common")))
(build-system r-build-system)
(propagated-inputs
@@ -41082,13 +41137,13 @@ Monte Carlo approach implemented in JAGS.")
(define-public r-logger
(package
(name "r-logger")
- (version "0.2.2")
+ (version "0.3.0")
(source
(origin
(method url-fetch)
(uri (cran-uri "logger" version))
(sha256
- (base32 "08kym5i5fvbf5xhh9qdszp4jdgyc7j7zpnwzy68wabqz73aff6sg"))))
+ (base32 "0ivhrmq408pb7gx7yhmrn6mjkx15dvkb4bpk4z5y642l3j2vv9vd"))))
(properties `((upstream-name . "logger")))
(build-system r-build-system)
(native-inputs (list r-knitr))