aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/compression.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/compression.scm')
-rw-r--r--gnu/packages/compression.scm58
1 files changed, 56 insertions, 2 deletions
diff --git a/gnu/packages/compression.scm b/gnu/packages/compression.scm
index 49c46a2093..6b91b51504 100644
--- a/gnu/packages/compression.scm
+++ b/gnu/packages/compression.scm
@@ -4,7 +4,7 @@
;;; Copyright © 2014, 2015, 2018 Mark H Weaver <mhw@netris.org>
;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
;;; Copyright © 2015, 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021 Ricardo Wurmus <rekado@elephly.net>
+;;; Copyright © 2015, 2016, 2017, 2018, 2020, 2021, 2022 Ricardo Wurmus <rekado@elephly.net>
;;; Copyright © 2015, 2017, 2018 Leo Famulari <leo@famulari.name>
;;; Copyright © 2015 Jeff Mickey <j@codemac.net>
;;; Copyright © 2015, 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
@@ -1392,6 +1392,32 @@ handles the 7z format which features very high compression ratios.")
functionality in a C++ iostream.")
(license license:lgpl2.1+)))
+(define-public zopfli
+ (package
+ (name "zopfli")
+ (version "1.0.3")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/google/zopfli")
+ (commit (string-append name "-" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0dr8n4j5nj2h9n208jns56wglw59gg4qm3s7c6y3hs75d0nnkhm4"))))
+ (build-system cmake-build-system)
+ (arguments
+ `(#:tests? #f ;no test suite
+ #:configure-flags '("-DBUILD_SHARED_LIBS=ON")))
+ (home-page "https://github.com/google/zopfli")
+ (synopsis "Very good, but slow, deflate or zlib compression")
+ (description "Zopfli Compression Algorithm is a compression library
+programmed in C to perform very good, but slow, deflate or zlib compression.
+ZopfliCompress supports the deflate, gzip and zlib output formats. This
+library can only compress, not decompress; existing zlib or deflate libraries
+can decompress the data.")
+ (license license:asl2.0)))
+
(define-public zpaq
(package
(name "zpaq")
@@ -2280,7 +2306,7 @@ API, and that means that you can also use QTextStream, QDataStream or
whatever you would like to use on your zipped files.
QuaZIP provides complete abstraction of the ZIP/UNZIP API, for both
-reading from and writing to ZIP archives. ")
+reading from and writing to ZIP archives.")
;; Project is distributed under LGPL, but "quazip/z*" "quazip/unzip.*" are
;; distributed under zlib terms.
(license (list license:lgpl2.1+ license:zlib))))
@@ -2708,3 +2734,31 @@ negotiation. These design goals make it different from earlier binary
serializations such as ASN.1 and MessagePack.")
(license license:expat)
(home-page "https://github.com/PJK/libcbor")))
+
+(define-public fcrackzip
+ (package
+ (name "fcrackzip")
+ (version "1.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "http://oldhome.schmorp.de/marc/data/"
+ "fcrackzip-" version ".tar.gz"))
+ (sha256
+ (base32
+ "0l1qsk949vnz18k4vjf3ppq8p497966x4c7f2yx18x8pk35whn2a"))))
+ (build-system gnu-build-system)
+ (arguments
+ (list
+ #:phases
+ '(modify-phases %standard-phases
+ (add-after 'unpack 'fix-reference-to-unzip
+ (lambda _
+ (substitute* "main.c"
+ (("\"unzip")
+ (string-append "\"" (which "unzip")))))))))
+ (inputs
+ (list perl unzip))
+ (home-page "http://oldhome.schmorp.de/marc/fcrackzip.html")
+ (synopsis "Zip password cracker")
+ (description "Fcrackzip is a Zip file password cracker.")
+ (license license:gpl2+)))