aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/chromium.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/chromium.scm')
-rw-r--r--gnu/packages/chromium.scm31
1 files changed, 22 insertions, 9 deletions
diff --git a/gnu/packages/chromium.scm b/gnu/packages/chromium.scm
index f06767f305..6a98867cc8 100644
--- a/gnu/packages/chromium.scm
+++ b/gnu/packages/chromium.scm
@@ -163,6 +163,7 @@
"third_party/google_input_tools/third_party/closure_library/third_party/closure" ;Expat
"third_party/googletest" ;BSD-3
"third_party/harfbuzz-ng" ;Expat
+ "third_party/highway" ;ASL2.0
"third_party/hunspell" ;MPL1.1/GPL2+/LGPL2.1+
"third_party/iccjpeg" ;IJG
"third_party/inspector_protocol" ;BSD-3
@@ -179,6 +180,7 @@
"third_party/libaom/source/libaom/third_party/fastfeat" ;BSD-3
"third_party/libaom/source/libaom/third_party/vector" ;Expat
"third_party/libaom/source/libaom/third_party/x86inc" ;ISC
+ "third_party/libjxl" ;ASL2.0
"third_party/libgav1" ;ASL2.0
"third_party/libgifcodec" ;MPL1.1/GPL2+/LGPL2.1+, BSD-3, BSD-2
"third_party/libjingle_xmpp" ;BSD-3
@@ -239,7 +241,6 @@
"third_party/rnnoise" ;BSD-3
"third_party/ruy" ;ASL2.0
"third_party/s2cellid" ;ASL2.0
- "third_party/schema_org" ;CC-BY-SA3.0
"third_party/securemessage" ;ASL2.0
"third_party/shell-encryption" ;ASL2.0
"third_party/skia" ;BSD-3
@@ -274,6 +275,7 @@
"third_party/wayland-protocols" ;Expat
"third_party/web-animations-js" ;ASL2.0
"third_party/webdriver" ;ASL2.0
+ "third_party/webgpu-cts" ;BSD-3
"third_party/webrtc" ;BSD-3
"third_party/webrtc/common_audio/third_party/ooura" ;Non-copyleft
"third_party/webrtc/common_audio/third_party/spl_sqrt_floor" ;Public domain
@@ -320,14 +322,14 @@
(string-append "ungoogled-chromium-" category "-" name))))
(sha256 (base32 hash))))
-(define %chromium-version "90.0.4430.212")
+(define %chromium-version "91.0.4472.77")
(define %debian-revision "debian/90.0.4430.85-1")
-(define %ungoogled-revision "90.0.4430.85-1-11-g3184907")
+;; Note: use 'git describe --long' even for exact tags to placate the
+;; custom version format for ungoogled-chromium.
+(define %ungoogled-revision "91.0.4472.77-1-0-g6802c88")
(define %debian-patches
- (list (debian-patch "fixes/missing-includes.patch"
- "1f0drxp1cy76g71rkkzxxbwixn03yn9b0q22vb0mb6h2qk6cw92q")
- (debian-patch "fixes/nomerge.patch"
+ (list (debian-patch "fixes/nomerge.patch"
"0lybs2b5gk08j8cr6vjrs9d3drd7qfw013z2r0y00by8dnpm74i3")
(debian-patch "system/nspr.patch"
"1gdirn1k1i841l8zp8xgr95kl16b5nx827am9rcxj8sfkm8hgkn3")
@@ -344,7 +346,7 @@
(file-name (git-file-name "ungoogled-chromium" %ungoogled-revision))
(sha256
(base32
- "18xfwgkw3xarxcgnzvyv70h4icyqh3k8lfx6fvhp7fsr6x20sai0"))))
+ "1jfmmkw1y4rcjfgsm7b4v2lrgd3sks5qpajvq0djflbhkpsqxfk0"))))
(define %guix-patches
(list (local-file
@@ -399,6 +401,11 @@
(format #t "Replacing GN files...~%")
(force-output)
+ ;; XXX: Chromium no longer relies on overriding ICU's UCHAR_TYPE,
+ ;; but the unbundling code was not updated. Remove for M92.
+ (substitute* "build/linux/unbundle/icu.gn"
+ (("\"UCHAR_TYPE=uint16_t\",")
+ ""))
(substitute* "tools/generate_shim_headers/generate_shim_headers.py"
;; The "is_official_build" configure option enables certain
;; release optimizations like those used in the commercial
@@ -481,7 +488,7 @@
%chromium-version ".tar.xz"))
(sha256
(base32
- "17nmhrkl81qqvzbh861k2mmifncx4wg1mv1fmn52f8gzn461vqdb"))
+ "0c8vj3gq3nmb7ssiwj6875g0a8hcprss1a4gqw9h7llqywza9ma5"))
(modules '((guix build utils)))
(snippet (force ungoogled-chromium-snippet))))
(build-system gnu-build-system)
@@ -630,6 +637,12 @@
(("include \"third_party/lcms/include/lcms2\\.h\"")
"include \"lcms2.h\""))
+ ;; Add missing include statement.
+ (substitute* "third_party/pdfium/core/fxcodec/png/png_decoder.cpp"
+ (("#include \"core/fxcodec/fx_codec.h\"" all)
+ (string-append all
+ "\n#include \"core/fxcodec/fx_codec_def.h\"")))
+
(substitute*
"third_party/breakpad/breakpad/src/common/linux/libcurl_wrapper.h"
(("include \"third_party/curl")
@@ -852,7 +865,7 @@
("glib" ,glib)
("gtk+" ,gtk+)
("harfbuzz" ,harfbuzz)
- ("icu4c" ,icu4c-68)
+ ("icu4c" ,icu4c-69)
("lcms" ,lcms)
("libevent" ,libevent)
("libffi" ,libffi)
mmit/gnu/packages/gcc.scm?id=0aed5bf5120bd434e53be0cea3f96547f95837d6'>gnu: gcc@4.9, gcc@5.5: Build with '-std=c++11'....These two compilers would fail to build with GCC 11.3.0 because it defaults to C++17, which triggers some incompatibilities. * gnu/packages/gcc.scm (gcc-4.7)[arguments]: Augment #:configure-flags for 4.9 and 5.0. (gcc-4.9)[arguments]: Define 'parent' so that (package-arguments parent) correctly evaluates the version-dependent parts. Ludovic Courtès 2023-03-02Merge remote-tracking branch 'savannah/master' into core-updates...Conflicts: gnu/local.mk gnu/packages/autotools.scm gnu/packages/cmake.scm gnu/packages/gnuzilla.scm gnu/packages/haskell.scm gnu/packages/pdf.scm gnu/packages/python-xyz.scm gnu/packages/samba.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/wxwidgets.scm Christopher Baines 2023-02-09gnu: Add gccgo-12....* gnu/packages/gcc.scm (gccgo-12): New variable. (make-gccgo)[arguments]: Adapt custom 'remove-tool-reference-from-libgo to changes in the source. Efraim Flashner 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2022-10-18gnu: gcc-2.95: Add initial work toward building for arm....* gnu/packages/gcc.scm (gcc-2.95)[source]: Adjust source to use newer macros from more recent versions of GCC. Efraim Flashner 2022-10-18gnu: gcc-2.95: Add substitution for the Hurd's linker....* gnu/packages/gcc.scm (gcc-2.95)[arguments]: Adjust custom 'set-dynamic-linker-file-name phase to also substitute the Hurd's linker. Efraim Flashner 2022-10-03gnu: isl: Remove outdated comment....* gnu/packages/gcc.scm (isl) [source]: Remove outdated comment. Maxim Cournoyer 2022-09-15Merge branch 'staging' into core-updates...Conflicts resolved in: gnu/local.mk gnu/packages/cmake.scm gnu/packages/glib.scm gnu/packages/gnome.scm gnu/packages/gtk.scm gnu/packages/sdl.scm pango-next, vala-next and librsvg-bootstrap were removed in the process. Maxim Cournoyer 2022-09-11gnu: libgccjit: Build multiple versions....* gnu/packages/gcc.scm (libgccjit-9, libgccjit-10, libgccjit-11) (libgccjit-12): New variables. (libgccjit): Update to libgccjit-10. Liliana Marie Prikler 2022-09-11gnu: libgccjit: Build with bootstrapped gcc....* gnu/packages/gcc.scm (make-libgccjit)[#:configure-flags]: Add “--disable-bootstrap”, “--disable-libatomic”, “--disable-libgomp”, “--disable-libquadmath”, “--disable-libssp”, and “--enable-checking=release”. [inputs]: Remove libstdc++. [native-inputs]: Add gcc. Liliana Marie Prikler 2022-09-11gnu: Parameterize libgccjit....* gnu/packages/gcc.scm (make-libgccjit): New variable. (libgccjit): Define in terms of make-libgccjit. Liliana Marie Prikler 2022-09-08gnu: Switch to GCC 11....* gnu/packages/commencement.scm (gcc-boot0)[source]: Delete offending files from GCC. (libstdc++-boot0)[arguments]: Add #:modules. (libstdc++): Inherit from from GCC-BOOT0 rather than GCC. (gcc-final)[arguments]: Add phase to workaround libstdc++ build system issue. Add #:modules. * gnu/packages/gcc.scm (make-libstdc++): Likewise. Marius Bakke 2022-08-27Merge branch 'staging' into core-updatesMarius Bakke 2022-08-27gnu: gcc-12: Update to 12.2.0....* gnu/packages/gcc.scm (gcc-12): Update to 12.2.0. Signed-off-by: Marius Bakke <marius@gnu.org> Greg Hogan 2022-07-27gnu: GCC: Fix union optimization issue....* gnu/packages/patches/gcc-10-tree-sra-union-handling.patch: New file. * gnu/local.mk (dist_patch_DATA): Adjust accordingly. * gnu/packages/gcc.scm (gcc-10, gcc-11)[source](patches): Add it. * gnu/packages/rust.scm (rust-bootstrap)[native-inputs]: Remove GCC-9. Marius Bakke 2022-07-23gnu: GCC: Build with Elfutils instead of libelf....* gnu/packages/gcc.scm (gcc-4.7)[inputs]: Change from LIBELF to ELFUTILS. Marius Bakke 2022-07-10gnu: gcc: Patch gcc for riscv unconditionally....* gnu/packages/gcc.scm (gcc-4.7)[arguments]: In custom 'pre-configure phase unconditionally remove STARTFILE_PREFIX_SPEC in all locations it may exist. Efraim Flashner 2022-06-29gnu: gcc-10: Update to 10.4.0....* gnu/packages/gcc.scm (gcc-10): Update to 10.4.0. Efraim Flashner 2022-06-27Merge branch 'master' into core-updatesMarius Bakke 2022-06-26gnu: isl: Update to 0.24....* gnu/packages/gcc.scm (isl): Update to 0.24. [source](uri): Use new .xz tarball. Marius Bakke 2022-06-26gnu: gcc-objc, gcc-objc++: Declare variants for GCC 11 and GCC 12....* gnu/packages/gcc.scm (gcc-objc-11, gcc-objc-12, gcc-objc++-11, gcc-objc++-12): New variables. Marius Bakke 2022-05-30gnu: gcc-9: Update to 9.5.0....* gnu/packages/gcc.scm (gcc-9): Update to 9.5.0. Efraim Flashner 2022-05-24gnu: gcc: Add 12.1.0....* gnu/packages/gcc.scm (gcc-12): New variable. Ludovic Courtès 2022-05-24gnu: gcc@11: Update 'compiler-cpu-architectures' property....* gnu/packages/gcc.scm (%gcc-11-aarch64-micro-architectures) (%gcc-11-armhf-micro-architectures) (%gcc-11-x86_64-micro-architectures): New variables. (gcc-11)[properties]: Use them. Ludovic Courtès