aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/boost.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/boost.scm')
-rw-r--r--gnu/packages/boost.scm57
1 files changed, 28 insertions, 29 deletions
diff --git a/gnu/packages/boost.scm b/gnu/packages/boost.scm
index 71999709ed..2fdea80896 100644
--- a/gnu/packages/boost.scm
+++ b/gnu/packages/boost.scm
@@ -67,41 +67,22 @@
(define-public boost
(package
(name "boost")
- (version "1.80.0")
+ (version "1.83.0")
(source (origin
(method url-fetch)
(uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
version "/source/boost_"
(version-with-underscores version) ".tar.bz2"))
(patches
- (list (boost-patch
- ;; Boost.Filesystem directory iterators may fail to
- ;; construct for a network share on Windows prior to 10:
- ;; https://github.com/boostorg/filesystem/pull/246,
- ;; https://github.com/boostorg/filesystem/issues/245
- "0001-filesystem-win-fix-dir-it-net-share.patch" version
- "067hhylqkzzdbqzc1hkbpaqmvz248lxqrdhb2yi6iq9qabsik3lk")
- (boost-patch
- ;; In Boost.Filesystem on Windows, weakly_canonical fails
- ;; to process paths that start with the "\\?\" prefix:
- ;; https://github.com/boostorg/filesystem/issues/247
- "0002-filesystem-fix-weakly-canonical-long-paths.patch" version
- "00w3albf8527glclx85p5b2ml3vr06xpwwmfyzg005v1cp8avcpi")
- (boost-patch
- ;; Boost.Unordered containers are not in a valid state
- ;; after moving:
- ;; https://github.com/boostorg/unordered/issues/139
- "0003-unordered-valid-after-move.patch" version
- "0dw839w22cawqawfpsx7j7v9y0x2vn66m732iidpxvdxbjn2kzva")
- (boost-patch
- ;; Fixed a missing include on POSIX systems that don't
- ;; support *at APIs:
- ;; https://github.com/boostorg/filesystem/issues/250
- "0004-filesystem-posix-fix-no-at-apis-missing-include.patch" version
- "09k8k3b1306jkjls12wfghj820n828j6aaxzmcr0wpnjhp8fzi1v")))
+ (append
+ (search-patches "boost-fix-duplicate-definitions-bug.patch")
+ (list (boost-patch
+ "0001-unordered-fix-copy-assign.patch" version
+ "09j61m5xh7099k5na9i43x5rra51znf7vm2nyh89yqpizcll9q66"))))
+ (patch-flags '("-p2"))
(sha256
(base32
- "1h00qp4z5k6lfz310xjwsmqs8fwxi6ngas51169cafz4h9fmc68y"))))
+ "13iviiwk1srpw9dmiwabkxv56v0pl0zggjp8zxy1419k5zzfsy34"))))
(build-system gnu-build-system)
(inputs
(append
@@ -114,9 +95,9 @@
(arguments
(list
#:imported-modules `((guix build python-build-system)
- ,@%gnu-build-system-modules)
+ ,@%default-gnu-imported-modules)
#:modules `(((guix build python-build-system) #:select (python-version))
- ,@%gnu-build-system-modules)
+ ,@%default-gnu-modules)
#:tests? #f
#:configure-flags
#~(let ((icu (dirname (dirname (search-input-file
@@ -225,6 +206,24 @@ across a broad spectrum of applications.")
(license (license:x11-style "https://www.boost.org/LICENSE_1_0.txt"
"Some components have other similar licences."))))
+(define-public boost-for-source-highlight
+ (hidden-package (package (inherit boost)
+ (name "boost")
+ (version "1.83.0")
+ (source (origin
+ (method url-fetch)
+ (uri (string-append "https://boostorg.jfrog.io/artifactory/main/release/"
+ version "/source/boost_"
+ (version-with-underscores version) ".tar.bz2"))
+ (patches
+ (list (boost-patch
+ "0001-unordered-fix-copy-assign.patch" version
+ "09j61m5xh7099k5na9i43x5rra51znf7vm2nyh89yqpizcll9q66")))
+ (patch-flags '("-p2"))
+ (sha256
+ (base32
+ "13iviiwk1srpw9dmiwabkxv56v0pl0zggjp8zxy1419k5zzfsy34")))))))
+
;; Sadly, this is needed for irods. It won't link with 1.69 or later.
(define-public boost-for-irods
(package