aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm45
1 files changed, 45 insertions, 0 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index 9ce28596c2..38c5195146 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -3312,6 +3312,51 @@ off-target reads for a capture method that targets CpG-rich region.")
multiple sequence alignments.")
(license license:expat)))
+(define-public python-mofax
+ ;; This is a recent commit from the "dev" branch, which is much more recent
+ ;; than the latest commit from the "master" branch.
+ (let ((commit "4d96f8f0a5d5251847353656f523684d66c3c47a")
+ (revision "0"))
+ (package
+ (name "python-mofax")
+ (version (git-version "0.4.0" revision commit))
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/bioFAM/mofax")
+ (commit commit)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "1lwrw0qyvvnyiqz1l20dhcf7dxidb80cqgvk78czvdgba87yxzqx"))
+ (modules '((guix build utils)))
+ ;; Prevent the pyproject-build-system from guessing that flit
+ ;; should be used as a builder.
+ (snippet '(substitute* "pyproject.toml"
+ (("^#.*") "")))))
+ (build-system pyproject-build-system)
+ (arguments
+ (list
+ ;; This test is failing due to a bug. The bug has been reported to the
+ ;; developers. See https://github.com/bioFAM/mofax/issues/12 for more
+ ;; info.
+ #:test-flags '(list "-k" "not test_get_methods")))
+ (propagated-inputs (list python-h5py
+ python-matplotlib
+ python-pandas
+ python-poetry-core
+ python-scipy
+ python-seaborn))
+ (native-inputs (list python-numpy python-pytest))
+ (home-page "https://github.com/bioFAM/mofax")
+ (synopsis
+ "Motif activity finder for transcription factor motif analysis")
+ (description
+ "MoFax is a Python package for transcription factor motif analysis.
+It provides convenience functions to load and visualize factor models trained
+with MOFA+ in Python.")
+ (license license:expat))))
+
(define-public python-pyega3
(package
(name "python-pyega3")