aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/bioinformatics.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/bioinformatics.scm')
-rw-r--r--gnu/packages/bioinformatics.scm8
1 files changed, 3 insertions, 5 deletions
diff --git a/gnu/packages/bioinformatics.scm b/gnu/packages/bioinformatics.scm
index f62f83c221..5797993500 100644
--- a/gnu/packages/bioinformatics.scm
+++ b/gnu/packages/bioinformatics.scm
@@ -8810,8 +8810,7 @@ selection, etc.).")
(("^rm -f mafft-distance mafft-distance.exe") ")#")
;; do not install MAN pages in libexec folder
(("^\t\\$\\(INSTALL\\) -m 644 \\$\\(MANPAGES\\) \
-\\$\\(DESTDIR\\)\\$\\(LIBDIR\\)") "#"))
- #t))
+\\$\\(DESTDIR\\)\\$\\(LIBDIR\\)") "#"))))
(add-after 'enter-dir 'patch-paths
(lambda* (#:key inputs #:allow-other-keys)
(substitute* '("pairash.c"
@@ -8819,8 +8818,7 @@ selection, etc.).")
(("perl") (which "perl"))
(("([\"`| ])awk" _ prefix)
(string-append prefix (which "awk")))
- (("grep") (which "grep")))
- #t))
+ (("grep") (which "grep")))))
(delete 'configure)
(add-after 'install 'wrap-programs
(lambda* (#:key inputs outputs #:allow-other-keys)
@@ -8833,7 +8831,7 @@ selection, etc.).")
`("PATH" ":" prefix (,path))))
(find-files bin))))))))
(inputs
- (list perl ruby gawk grep coreutils))
+ (list bash-minimal perl ruby gawk grep coreutils))
(home-page "https://mafft.cbrc.jp/alignment/software/")
(synopsis "Multiple sequence alignment program")
(description