aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/backup.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/backup.scm')
-rw-r--r--gnu/packages/backup.scm21
1 files changed, 1 insertions, 20 deletions
diff --git a/gnu/packages/backup.scm b/gnu/packages/backup.scm
index 8d7c9953a4..9b69873ced 100644
--- a/gnu/packages/backup.scm
+++ b/gnu/packages/backup.scm
@@ -260,7 +260,6 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(define-public libarchive
(package
(name "libarchive")
- (replacement libarchive/fixed)
(version "3.6.1")
(source
(origin
@@ -270,6 +269,7 @@ backups (called chunks) to allow easy burning to CD/DVD.")
(string-append "https://github.com/libarchive/libarchive"
"/releases/download/v" version "/libarchive-"
version ".tar.xz")))
+ (patches (search-patches "libarchive-remove-potential-backdoor.patch"))
(sha256
(base32
"1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas"))))
@@ -349,25 +349,6 @@ random access nor for in-place modification. This package provides the
@command{bsdcat}, @command{bsdcpio} and @command{bsdtar} commands.")
(license license:bsd-2)))
-(define-public libarchive/fixed
- (hidden-package
- (package
- (inherit libarchive)
- (version "3.6.1")
- (source
- (origin
- (method url-fetch)
- (uri (list (string-append "https://libarchive.org/downloads/libarchive-"
- version ".tar.xz")
- (string-append "https://github.com/libarchive/libarchive"
- "/releases/download/v" version "/libarchive-"
- version ".tar.xz")))
- (patches (search-patches "libarchive-remove-potential-backdoor.patch"))
- (sha256
- (base32
- "1rj8q5v26lxxr8x4b4nqbrj7p06qvl91hb8cdxi3xx3qp771lhas")))))))
-
-
(define-public rdup
(package
(name "rdup")