aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 431bd0346e..4d1bbcec87 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -3140,9 +3140,12 @@ image processing functions: @code{xyxymatch}, @code{geomap}.")
(list
#:phases
#~(modify-phases %standard-phases
- ;; XXX: Can't detect opencv-python version. The input opencv might
- ;; not set the version correctly.
- (delete 'sanity-check)
+ (add-before 'build 'silent-check-for-opencv
+ (lambda _
+ ;; XXX: Can't detect opencv-python version. The input opencv
+ ;; might not set the version correctly.
+ (substitute* "pyproject.toml"
+ ((".*opencv-python-headless.*") ""))))
(add-before 'check 'build-extensions
(lambda _
;; Cython extensions have to be built before running the tests.