aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/astronomy.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/astronomy.scm')
-rw-r--r--gnu/packages/astronomy.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/astronomy.scm b/gnu/packages/astronomy.scm
index 3ca8c50b9a..7e69584127 100644
--- a/gnu/packages/astronomy.scm
+++ b/gnu/packages/astronomy.scm
@@ -663,6 +663,36 @@ covers the same surface area as every other pixel. This package provides the
dynamic library for the C language implementation of HEALPix.")
(license license:gpl2+)))
+(define-public healpix-cxx
+ (package
+ (inherit healpix)
+ (name "healpix-cxx")
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'chdir-cxx
+ (lambda _
+ (chdir "src/cxx")))
+ (add-after 'chdir-cxx 'adjust-unit-tests
+ (lambda _
+ (substitute* "configure.ac"
+ ;; Run unit tests using serial harness, taken from
+ ;; <https://salsa.debian.org/debian-astro-team/healpix-cxx/>.
+ (("foreign subdir-objects -Wall -Werror")
+ "foreign serial-tests subdir-objects -Wall -Werror"))))
+ (replace 'bootstrap
+ (lambda _
+ (invoke "aclocal")
+ (invoke "automake" "--add-missing")
+ (invoke "autoconf"))))))
+ (inputs (modify-inputs (package-inputs healpix)
+ (prepend libsharp zlib)))
+ (description
+ (string-replace-substring (package-description healpix)
+ "C language"
+ "C++ language"))))
+
(define-public erfa
(package
(name "erfa")