aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/assembly.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/assembly.scm')
-rw-r--r--gnu/packages/assembly.scm25
1 files changed, 17 insertions, 8 deletions
diff --git a/gnu/packages/assembly.scm b/gnu/packages/assembly.scm
index 33ccc70e76..ca50b00a06 100644
--- a/gnu/packages/assembly.scm
+++ b/gnu/packages/assembly.scm
@@ -3,7 +3,7 @@
;;; Copyright © 2013, 2015 Ludovic Courtès <ludo@gnu.org>
;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
;;; Copyright © 2016, 2020, 2021 Efraim Flashner <efraim@flashner.co.il>
-;;; Copyright © 2017–2021 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017–2022 Tobias Geerinckx-Rice <me@tobias.gr>
;;; Copyright © 2019 Guy Fleury Iteriteka <hoonandon@gmail.com>
;;; Copyright © 2019 Andy Tai <atai@atai.org>
;;; Copyright © 2020 Jakub Kądziołka <kuba@kadziolka.net>
@@ -11,6 +11,7 @@
;;; Copyright © 2020 B. Wilson <elaexuotee@wilsonb.com>
;;; Copyright © 2021 Maxim Cournoyer <maxim.cournoyer@gmail.com>
;;; Copyright © 2021 Guillaume Le Vaillant <glv@posteo.net>
+;;; Copyright © 2022 Felix Gruber <felgru@posteo.net>
;;;
;;; This file is part of GNU Guix.
;;;
@@ -181,14 +182,14 @@ speed on x86, NEON on ARM, etc.).")
(define-public fasm
(package
(name "fasm")
- (version "1.73.29")
+ (version "1.73.30")
(source
(origin
(method url-fetch)
(uri (string-append "https://flatassembler.net/fasm-"
version ".tgz"))
(sha256
- (base32 "0ar1k1504cmwi49y6g254rkzayll0kn90vjd4zj09xv86kcg8a33"))))
+ (base32 "00giqb94z8cxhv20yiyk8axkd2kzjcg1c0841yzbn7c8lm8m06bm"))))
(build-system gnu-build-system)
(arguments
`(#:tests? #f ; no tests exist
@@ -342,7 +343,7 @@ package for the Game Boy and Game Boy Color. It consists of:
(define-public wla-dx
(package
(name "wla-dx")
- (version "9.12")
+ (version "10.1")
(source (origin
(method git-fetch)
(uri (git-reference
@@ -351,12 +352,20 @@ package for the Game Boy and Game Boy Color. It consists of:
(file-name (git-file-name name version))
(sha256
(base32
- "1wlbqv2rgk9q6m9an1mi0i29250zl8lw7zipki2bbi9mczpyczli"))))
+ "1nh2k2xn5fj389gq68f3fxgrxakgn8c6dw2ffqay86s3706hac9w"))))
(build-system cmake-build-system)
- (native-inputs
- `(("sphinx" ,python-sphinx))) ; to generate man pages
+ (native-inputs (list python-sphinx)) ; to generate man pages
(arguments
- `(#:tests? #f)) ; no tests
+ `(#:phases
+ (modify-phases %standard-phases
+ (add-before 'check 'copy-tests-to-build-directory
+ (lambda _
+ (copy-recursively "../source/tests" "tests")))
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (let ((sh (which "sh")))
+ (when tests?
+ (invoke sh "../source/run_tests.sh"))))))))
(home-page "https://github.com/vhelin/wla-dx")
(synopsis "Assemblers for various processors")
(description "WLA DX is a set of tools to assemble assembly files to