aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages/algebra.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages/algebra.scm')
-rw-r--r--gnu/packages/algebra.scm11
1 files changed, 5 insertions, 6 deletions
diff --git a/gnu/packages/algebra.scm b/gnu/packages/algebra.scm
index 2a17ea59b6..c889433b41 100644
--- a/gnu/packages/algebra.scm
+++ b/gnu/packages/algebra.scm
@@ -315,7 +315,7 @@ fast arithmetic.")
(define-public arb
(package
(name "arb")
- (version "2.13.0")
+ (version "2.14.0")
(source (origin
(method url-fetch)
(uri (string-append
@@ -324,7 +324,7 @@ fast arithmetic.")
(file-name (string-append name "-" version ".tar.gz"))
(sha256
(base32
- "123p3gwx0s3i88rcaj3g4jl37cr3pywhpqackipskzab15ni2xfh"))))
+ "0ncr27nd20xxi18nj30cvpa6r52v59nq7gbi34x3l4xym3p8mlmx"))))
(build-system gnu-build-system)
(propagated-inputs
`(("flint" ,flint))) ; flint.h is included by arf.h
@@ -342,19 +342,18 @@ fast arithmetic.")
(mpfr (assoc-ref inputs "mpfr")))
;; do not pass "--enable-fast-install", which makes the
;; homebrew configure process fail
- (zero? (system*
- "./configure"
+ (invoke "./configure"
(string-append "--prefix=" out)
(string-append "--with-flint=" flint)
(string-append "--with-gmp=" gmp)
- (string-append "--with-mpfr=" mpfr)))))))))
+ (string-append "--with-mpfr=" mpfr))))))))
(synopsis "Arbitrary precision floating-point ball arithmetic")
(description
"Arb is a C library for arbitrary-precision floating-point ball
arithmetic. It supports efficient high-precision computation with
polynomials, power series, matrices and special functions over the
real and complex numbers, with automatic, rigorous error control.")
- (license license:gpl2+)
+ (license license:lgpl2.1+)
(home-page "http://fredrikj.net/arb/")))
(define-public ntl
tle='2018-10-15 06:19:37 +0200'>2018-10-15gnu: restic: Update to 0.9.3....Tobias Geerinckx-Rice 2018-10-07gnu: borg: The backup client cannot override the server-side storage quota....Leo Famulari 2018-09-11gnu: obnam: Add deprecation warning....Tobias Geerinckx-Rice 2018-08-30gnu: duplicity: Update to 0.7.18.1....Tobias Geerinckx-Rice 2018-08-23gnu: duplicity: Update to 0.7.18....Tobias Geerinckx-Rice 2018-08-19gnu: libchop: Fix build and test errors....Ludovic Courtès 2018-08-19gnu: libchop: Require gperf 3.0....Ludovic Courtès 2018-08-19Merge branch 'staging'Marius Bakke 2018-08-17gnu: restic: Set a variable to disable FUSE tests....Oleg Pykhalov 2018-08-16Merge branch 'master' into stagingMarius Bakke 2018-08-15gnu: restic: Update to 0.9.2....Oleg Pykhalov 2018-08-12gnu: borg: Update to 1.1.7....Leo Famulari 2018-08-10Merge branch 'master' into stagingMarius Bakke 2018-08-08gnu: restic: Fix tests....Oleg Pykhalov 2018-08-07Merge branch 'master' into stagingMarius Bakke 2018-08-04gnu: Patch duplicity with --ignore-mdc-error....Christopher Baines 2018-07-19gnu: borg: Update the list of Cython-generated files to delete....Leo Famulari 2018-06-26gnu: obnam: Return #t from phases....Tobias Geerinckx-Rice 2018-06-26gnu: borg: Return #t from all phases....Tobias Geerinckx-Rice 2018-06-26gnu: rsnapshot: Return #t from phases....Tobias Geerinckx-Rice 2018-06-26gnu: par2cmdline: Return #t from phases....Tobias Geerinckx-Rice 2018-06-18gnu: restic: Update the comment about the bundled dependencies....Leo Famulari 2018-06-16gnu: Add restic....Oleg Pykhalov 2018-06-12gnu: borg: Update to 1.1.6....Leo Famulari 2018-06-08gnu: duplicity: Update to 0.7.17....Oleg Pykhalov 2018-04-10Merge branch 'master' into core-updatesMark H Weaver