aboutsummaryrefslogtreecommitdiff
path: root/gnu/packages.scm
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/packages.scm')
-rw-r--r--gnu/packages.scm21
1 files changed, 19 insertions, 2 deletions
diff --git a/gnu/packages.scm b/gnu/packages.scm
index 97e6cb347f..44a56dfde0 100644
--- a/gnu/packages.scm
+++ b/gnu/packages.scm
@@ -110,8 +110,25 @@ for system '~a'")
file-name system)))))))
(define %distro-root-directory
- ;; Absolute file name of the module hierarchy.
- (dirname (search-path %load-path "guix.scm")))
+ ;; Absolute file name of the module hierarchy. Since (gnu packages …) might
+ ;; live in a directory different from (guix), try to get the best match.
+ (letrec-syntax ((dirname* (syntax-rules ()
+ ((_ file)
+ (dirname file))
+ ((_ file head tail ...)
+ (dirname (dirname* file tail ...)))))
+ (try (syntax-rules ()
+ ((_ (file things ...) rest ...)
+ (match (search-path %load-path file)
+ (#f
+ (try rest ...))
+ (absolute
+ (dirname* absolute things ...))))
+ ((_)
+ #f))))
+ (try ("gnu/packages/base.scm" gnu/ packages/)
+ ("gnu/packages.scm" gnu/)
+ ("guix.scm"))))
(define %package-module-path
;; Search path for package modules. Each item must be either a directory
date to 32.Timotej Lazar * gnu/packages/crypto.scm (signify): Update to 32. Change-Id: I5dedc5d8c6e0acb5bec94befe5aafd1642edb68e Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2024-02-20gnu: rust-crypto: Move to (gnu packages crates-crypto).Efraim Flashner * gnu/packages/crates-io.scm (rust-crypto-secretbox-0.1, rust-crypto-bigint-0.5, rust-crypto-bigint-0.4, rust-crypto-bigint-0.3, rust-crypto-bigint-0.2, rust-crypto-common-0.1, rust-crypto-mac-0.11, rust-crypto-mac-0.10, rust-crypto-mac-0.8, rust-crypto-mac-0.7, rust-crypto-mac-0.5, rust-crypto-mac-0.4, rust-crypto-tests-0.5, rust-crypto-hash-0.3): Move from here ... * gnu/packages/crates-crypto.scm: ... to here. Change-Id: Ice6d8f1b35afe75f1b0219dc1288ddd4ac8ab4a8 2024-02-13gnu: go-golang-org-x-crypto: Move to golang-build.Sharlatan Hellseher * gnu/packages/golang.scm (go-golang-org-x-crypto): Move from here ... * gnu/packages/golang-build.scm: ... to here. * gnu/packages/backup.scm: Add (gnu packages golang-build) module. * gnu/packages/crypto.scm: As above. Change-Id: I5daad7fe90e1507958fe73c04fc043ebbc006395 2023-10-18Revert "build: cargo-build-system: Disable tests by default."Efraim Flashner This reverts commit 37667443074a6de29f7665868f102111d62f0af9. This change needs more discussion. 2023-10-18build: cargo-build-system: Disable tests by default.Efraim Flashner * guix/build-system/cargo.scm (cargo-build): Disable tests by default. * gnu/packages/admin.scm (greetd, wlgreet, du-dust), * gnu/packages/bioinformatics.scm (circtools, python-gseapy), * gnu/packages/crypto.scm (rust-minisign, b3sum), * gnu/packages/gnome.scm (librsvg), * gnu/packages/python-crypto.scm (python-blake3, python-cryptography-rust), * gnu/packages/python-xyz.scm (python-orjson), * gnu/packages/rust-apps.scm (agate, alfis, bat, diffr, drill, dutree, exa, fd, hexyl, hyperfine, i3status-rust, just, maturin, ripgrep, rot8, rust-swc, rust-cargo-edit, git-interactive-rebase-tool, rust-cbindgen, rust-cbindgen-0.24, rust-cbindgen-0.19, sniffglue, tectonic, treefmt, hex, tokei, vivid, watchexec, rbw, rust-analyzer, rust-cargo-c, rtss, skim, skim-0.7, svd2rust, swayhide, tealdeer, git-absorb, zoxide, htmlq), * gnu/packages/sequoia.scm (sequoia-sqv), * gnu/packages/syndication.scm (newsboat), * gnu/packages/terminals.scm (alacritty), * gnu/packages/text-editors.scm (kak-lsp, parinfer-rust), * gnu/packages/tree-sitter.scm (tree-sitter-cli), * gnu/packages/video.scm (rav1e), * gnu/packages/web.scm (monolith, castor) [arguments]: Enable tests. 2023-10-18gnu: b3sum: Update to 1.5.0.Efraim Flashner * gnu/packages/crypto.scm (b3sum): Update to 1.5.0. [cargo-inputs]: Replace rust-blake3-0.3 with 1, rust-clap-2 with 4. Remove rust-memmap-0.7. Add rust-memmap2-0.7. 2023-10-18gnu: rust-blake3-1: Update to 1.5.0.Efraim Flashner * gnu/packages/crypto.scm (rust-blake3-1): Update to 1.5.0. [source]: Download using url-fetch. [arguments]: Skip tests. [cargo-inputs]: Add rust-memmap2-0.7, rust-serde-1, rust-zerioze-1. Replace rust-constant-time-eq-0.1 with 0.3, rust-digest-0.9 with 0.10. Remove rust-crypto-mac-0.11. [cargo-development-inputs]: Add rust-serde-json-1, rust-tempfile-3. Replace rust-page-size-0.4 with 0.6. Remove rust-cc-1. 2023-10-18gnu: rust-minisign: Update to 0.7.5.Efraim Flashner * gnu/packages/crates-io.scm (rust-minisign): Update to 0.7.5. [cargo-inputs]: Replace rust-getrandom-0.1 with 0.2, rust-rpassword-4 with 7, rust-scrypt-0.3 with 0.11. 2023-10-17gnu: crypto++: Add tunable property.Jean-Pierre De Jesus DIAZ * gnu/packages/crypto.scm (crypto++): Set tunable? property to true. Signed-off-by: Christopher Baines <mail@cbaines.net> 2023-10-17gnu: crypto++: Update to 8.8.0.Jean-Pierre De Jesus DIAZ * gnu/packages/crypto.scm (crypto++): Update to 8.8.0. [arguments]: Update to new style. Remove .so symbolic link installation as the project does it now. Fix cross-compilation for GNU/Linux and MinGW targets. Signed-off-by: Christopher Baines <mail@cbaines.net>