aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnu/local.mk')
-rw-r--r--gnu/local.mk1
1 files changed, 0 insertions, 1 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index 2355a80b1f..f0a59f1658 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1729,7 +1729,6 @@ dist_patch_DATA = \
%D%/packages/patches/python-sgmllib3k-assertions.patch \
%D%/packages/patches/python-telingo-fix-comparison.patch \
%D%/packages/patches/python-typeguard-python3.10.patch \
- %D%/packages/patches/python-w3lib-fix-test-failure.patch \
%D%/packages/patches/python-wxwidgets-type-errors.patch \
%D%/packages/patches/qtdeclarative-5-disable-qmlcache.patch \
%D%/packages/patches/qtdeclarative-disable-qmlcache.patch \
'ctx'> (method url-fetch)
(uri (string-append "https://github.com/rdesktop/rdesktop/"
@@ -54,32 +56,20 @@
version ".tar.gz"))
(sha256
(base32
- "0bfd9nl2dfr1931fv6bpnrj5yf88ikijrs4s3nm96gm87bkvi64v"))))
+ "1222f2srlq16bydhy44gph997iajg39sl774xxh9jdwi4cqjyg27"))))
(build-system gnu-build-system)
(arguments
- `(#:configure-flags (list (string-append "--with-openssl="
- (assoc-ref %build-inputs
- "openssl"))
-
- ;; XXX: optional dependencies missing
+ `(#:configure-flags (list ;; XXX: optional dependencies missing
"--disable-credssp"
"--disable-smartcard")
-
- #:phases
- (modify-phases %standard-phases
- (add-after 'install-license-files 'delete-extraneous-files
- (lambda* (#:key outputs #:allow-other-keys)
- (let* ((out (assoc-ref outputs "out"))
- (license-dir (string-append out "/share/doc/"
- ,name "-" ,version)))
- ;; XXX These files are installed erroneously.
- (delete-file (string-append license-dir "/licence.c"))
- (delete-file (string-append license-dir "/licence.o")))
- #t)))
- #:tests? #f)) ;no 'check' target
+ #:tests? #f)) ; No 'check' target
+ (native-inputs
+ `(("pkg-config" ,pkg-config)))
(inputs
- `(("libx11" ,libx11)
- ("openssl" ,openssl)))
+ `(("gnutls" ,gnutls)
+ ("libx11" ,libx11)
+ ("libxcursor" ,libxcursor)
+ ("nettle" ,nettle)))
(home-page "https://www.rdesktop.org/")
(synopsis "Client for Windows Terminal Services")
(description