aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am9
1 files changed, 6 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 77c05ff63b..ba440b1ac8 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -1009,16 +1009,19 @@ gen-tarball-version:
echo $(SOURCE_DATE_EPOCH) > $(distdir)/.tarball-timestamp
gen-ChangeLog:
- $(AM_V_GEN)set -e; \
+ $(AM_V_GEN)if test -d $(top_srcdir)/.git; then \
+ set -e; \
export LC_ALL=en_US.UTF-8; \
export TZ=UTC0; \
$(top_srcdir)/build-aux/gitlog-to-changelog \
> $(distdir)/ChangeLog.tmp; \
rm -f $(distdir)/ChangeLog; \
- mv $(distdir)/ChangeLog.tmp $(distdir)/ChangeLog;
+ mv $(distdir)/ChangeLog.tmp $(distdir)/ChangeLog; \
+ fi
gen-AUTHORS:
- $(AM_V_GEN)set -e; \
+ $(AM_V_GEN)if test -d $(top_srcdir)/.git; then \
+ set -e; \
rm -f "$(distdir)/AUTHORS"; \
export LC_ALL=en_US.UTF-8; \
export TZ=UTC0; \