aboutsummaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am6
1 files changed, 3 insertions, 3 deletions
diff --git a/Makefile.am b/Makefile.am
index 24a803a21a..35d72f36fe 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -655,9 +655,9 @@ release: dist
echo "failed to produced GuixSD installation image for $$system" >&2 ; \
exit 1 ; \
fi ; \
- xz < "$$image" > "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz.tmp" ; \
- mv "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz.tmp" \
- "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.xz" ; \
+ xz < "$$image" > "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz.tmp" ; \
+ mv "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz.tmp" \
+ "$(releasedir)/$(GUIXSD_IMAGE_BASE).$$system.iso.xz" ; \
done
for system in $(GUIXSD_VM_SYSTEMS) ; do \
image=`$(top_builddir)/pre-inst-env \
lete variable. 2023-03-28gnu: ruby-protobuf: Update to 3.10.3.Maxim Cournoyer * gnu/packages/protobuf.scm (ruby-protobuf): Update to 3.10.3. Delete trailing #t. [arguments]: Use search-input-file in patch-protoc phase. Honor #:tests? in check phase. 2023-03-28gnu: ruby-activesupport: Update to 7.0.4.3.Maxim Cournoyer * gnu/packages/ruby.scm (ruby-activesupport): Move to... * gnu/packages/rails.scm (ruby-activesupport): ... here. (%ruby-rails-version, ruby-rails-monorepo): New variables. (ruby-activesupport): Update to 7.0.4.3. [arguments]: Use gexps. Add the delete-gemfiles, chdir, check-setup and delete-problematic-tests phases. Delete check phase override. [native-inputs]: New field. [propagated-inputs]: Remove ruby-zeitwerk. Replace ruby-minitest with ruby-minitest-5.15. [home-page]: Update URL. 2023-03-28gnu: Remove ruby-protobuf-cucumber.Maxim Cournoyer The package is no longer used by ruby-cucumber-messages, its sole user. It is unmaintained. * gnu/packages/protobuf.scm (ruby-protobuf-cucumber): Delete variable. 2022-12-04gnu: python-protobuf@3.6: Fix inputs and arguments.Ludovic Courtès Fixes a regression introduced in 9b016e29912b11f52e67e59b211fa016d88fea4a, whereby the 'inputs' field would be invalid, plus "--cpp_implementation" wouldn't work. * gnu/packages/protobuf.scm (python-protobuf-3.6)[arguments]: New field. [inputs]: No longer refer to the inputs of PYTHON-PROTOBUF. 2022-12-02gnu: python-protobuf: Use C++ implementation.Ontje Lünsdorf * gnu/packages/protobuf.scm (python-protobuf): Use C++ implementation. [inputs]: Add protobuf. [arguments]: Add --cpp_implementation configure flags. Signed-off-by: Ludovic Courtès <ludo@gnu.org> 2022-11-22gnu: protobuf@3.5: Inherit from protobuf@3.6.Marius Bakke * gnu/packages/protobuf.scm (protobuf-3.5): Change inheritance, so it gets the correct build system and phases. 2022-11-20gnu: protobuf@2: Fix build.Marius Bakke * gnu/packages/protobuf.scm (protobuf-2)[build-system]: Set to GNU-BUILD-SYSTEM. [arguments]: Clear. [outputs]: Remove "static". 2022-11-14gnu: protobuf-2: Use gexp in arguments.Christopher Baines This fixes the breakage introduced when the protobuf package switched to using gexp's in the arguments. The package doesn't build, but at least the builder is now deterministic and valid Guile. * gnu/packages/protobuf.scm (protobuf-2)[arguments]: Adapt to use gexp's. 2022-11-11gnu: Add protobuf-c-for-aiscm.Ricardo Wurmus * gnu/packages/protobuf.scm (protobuf-c-for-aiscm): New variable. 2022-11-06gnu: protobuf-c: Update to 1.4.1.Maxim Cournoyer * gnu/packages/protobuf.scm (protobuf-c): Update to 1.4.1. 2022-11-06gnu: protobuf: Unbundle googletest.Maxim Cournoyer * gnu/packages/protobuf.scm (protobuf) [origin]: Delete third_party directory in snippet. [configure-flags]: Add "-Dprotobuf_USE_EXTERNAL_GTEST=ON". [native-inputs]: Add googletest. 2022-11-06gnu: protobuf: Update to 3.21.9.Maxim Cournoyer * gnu/packages/protobuf.scm (protobuf): Update to 3.21.9. Move outputs field before build system. Move inputs field below arguments. [source]: Apply patch and update URL. [build-system]: Use cmake-build-system. This causes the CMake support files to be installed, which is expected by some packages such as hyperledger-iroha. [arguments]: Use gexps. [configure-flags]: Add BUILD_SHARED_LIBS=ON. [phases]: Add set-c++-standard. [home-page]: Update URL. (protobuf-3.6): Adjust to continue using the gnu-build-system. * gnu/packages/patches/protobuf-fix-build-on-32bit.patch: New patch. * gnu/local.mk (dist_patch_DATA): Register it. 2022-10-27gnu: python-mypy-protobuf: Switch to pyproject-build-system.Marius Bakke * gnu/packages/protobuf.scm (python-mypy-protobuf)[build-system]: Switch to PYPROJECT-BUILD-SYSTEM. [arguments]: Remove redundant phases. [native-inputs]: Remove PYTHON-PYPA-BUILD. 2022-08-31gnu: Add python-mypy-protobuf.Maxim Cournoyer * gnu/packages/protobuf.scm (python-mypy-protobuf): New variable. 2022-08-31gnu: Add python-nanopb.Maxim Cournoyer * gnu/packages/protobuf.scm (python-nanopb): New variable. 2022-08-31gnu: Add nanopb.Maxim Cournoyer * gnu/packages/protobuf.scm (nanopb): New variable. 2022-07-24gnu: fstrm: Refer to HPND licence by name.Tobias Geerinckx-Rice * gnu/packages/protobuf.scm (fstrm)[license]: Use license:hpnd directly. 2022-07-24gnu: fstrm: Omit static library.Tobias Geerinckx-Rice * gnu/packages/protobuf.scm (fstrm)[arguments]: Add "--disable-static" to #:configure-flags. 2022-07-24gnu: fstrm: Update to 0.6.1.Tobias Geerinckx-Rice * gnu/packages/protobuf.scm (fstrm): Update to 0.6.1. [license]: Update too. 2022-07-12gnu: protobuf-2: Fix build.Maxim Cournoyer Partially fixes <https://issues.guix.gnu.org/51093>. * gnu/packages/protobuf.scm (protobuf-2) [phases]{disable-broken-tests}: Delete phase. 2022-05-31gnu: Remove python2-protobuf.Maxim Cournoyer * gnu/packages/protobuf.scm (python2-protobuf): Delete variable. 2022-05-27gnu: python-protobuf-3.6: Add missing input.Christopher Baines This was removed from python-protobuf in 5f8491ea95d7ba88801aa28b6d2b98f30b033186. * gnu/packages/protobuf.scm (python-protobuf-3.6)[inputs]: Add python-six. 2022-05-20gnu: Add python-proto-plus.Ricardo Wurmus * gnu/packages/protobuf.scm (python-proto-plus): New variable. 2022-05-20gnu: python-protobuf: Update to 3.20.1.Ricardo Wurmus * gnu/packages/protobuf.scm (python-protobuf): Update to 3.20.1. [native-inputs]: Remove python-wheel. [propagated-inputs]: Remove python-six.