aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm30
1 files changed, 30 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 820e6b54ab..4c6e8e63f0 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -9775,3 +9775,33 @@ Features:
"@code{go-github-com-go-chi-chi-v5} is an HTTP router that lets the user
decompose request handling into many smaller layers.")
(license license:expat)))
+
+(define-public go-sigs-k8s-io-yaml
+ (package
+ (name "go-sigs-k8s-io-yaml")
+ (version "1.3.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/kubernetes-sigs/yaml")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0qxs0ppqwqrfqs4aywyn1h28xh1qlj5ds4drmygaz1plrxj02dqn"))))
+ (build-system go-build-system)
+ (arguments '(#:import-path "sigs.k8s.io/yaml"))
+ (propagated-inputs (list go-gopkg-in-yaml-v2 go-github-com-davecgh-go-spew))
+ (home-page "https://sigs.k8s.io/yaml")
+ (synopsis "YAML marshaling and unmarshaling support for Go")
+ (description
+ "This package provides a Go library that first converts YAML to JSON
+using @code{go-yaml} and then uses @code{json.Marshal} and
+@code{json.Unmarshal} to convert to or from the struct. This means that
+it effectively reuses the JSON struct tags as well as the custom JSON
+methods @code{MarshalJSON} and @code{UnmarshalJSON} unlike
+@code{go-yaml}.
+
+kubernetes-sigs/yaml is a permanent fork of
+@url{https://github.com/ghodss/yaml,ghodss/yaml}.")
+ (license (list license:expat license:bsd-3))))
mit/etc/news.scm?id=5f0474ba878e49c0c0a8e9d6e67a7ad36f4ec955'>news: Add entry for 'core-updates' merge....* etc/news.scm: Add entry. Ludovic Courtès 2023-04-07news: Add entry for the linux-libre-lts 6.1 update....* etc/news.scm: Add entry. Jonathan Brielmaier 2023-04-07news: Add 'de' translation....* etc/news.scm: Add German translation of 'guix shell -CW' entry. Florian Pelz 2023-04-06news: Add entry for 'guix shell --container --nesting'....* etc/news.scm: Add entry. Ludovic Courtès 2023-03-11news: Add entry for the linux-libre 6.2 update....* etc/news.scm: Add entry. Leo Famulari 2023-02-19news: Fix commit for the guix pack new RPM format news....* etc/news.scm: Adjust latest news commit. Maxim Cournoyer 2023-02-19news: Add entry for the new 'rpm' guix pack format....* etc/news.scm: Add entry. Maxim Cournoyer 2023-01-16news: Fix formatting....* etc/news.scm: Add backslash to '--with-version' entry. Florian Pelz 2023-01-16news: Fix 'de' translation....* etc/news.scm: Add heading. Florian Pelz 2023-01-16news: Add entry for '--with-version'....* etc/news.scm: Add entry. Co-authored-by: Florian Pelz <pelzflorian@pelzflorian.de> Ludovic Courtès 2023-01-14news: Add 'de' translation....* etc/news.scm: Add German translation of entry about linux-libre 6.0 removal. Florian Pelz 2023-01-13news: Add entry about the removal of linux-libre 6.0....* etc/news.scm: Add entry Leo Famulari 2023-01-13news: Update 'de', 'fr', 'pt_BR' translation....* etc/news.scm: Add the usual translations for kernel news. Florian Pelz 2023-01-13news: Add entry for the linux-libre 6.1 update....* etc/news.scm: Add entry. Leo Famulari 2023-01-09news: Add 'de' translation....* etc/news.scm: Add German translation of entry about linux-libre 4.9 removal. Florian Pelz 2023-01-08news: Add entry about the removal of linux-libre 4.9....* etc/news.scm: Add entry. Leo Famulari 2022-12-11news: Fix typos in French text....* etc/news.scm: Fix typos. Signed-off-by: Julien Lepiller <julien@lepiller.eu> Vivien Kraus via Guix-patches via 2022-12-10news: Add 'fr' translation....* etc/news.scm: Add French translation of 'customize-linux' entry. Julien Lepiller 2022-12-08news: Add 'de' translation....* etc/news.scm: Add German translation of 'customize-linux' entry. Florian Pelz 2022-12-07news: Add entry for 'customize-linux'....* etc/news.scm: Add entry. Maxim Cournoyer 2022-11-16news: Add 'de' translation....* etc/news.scm: Add German translation of '--symlink' entry. Florian Pelz 2022-11-15news: Add entry for 'guix shell --symlink'....* etc/news.scm: Add entry. Maxim Cournoyer 2022-11-15etc/news.scm: Normalize indentation....* etc/news.scm: Normalize indentation. Maxim Cournoyer 2022-11-07news: Update 'de', 'fr', 'pt_BR' translation....* etc/news.scm: Add the usual translations for kernel news. Florian Pelz 2022-11-06news: Add entry about the update of the 'linux-libre' package....* etc/news.scm: Add entry. Leo Famulari 2022-11-05news: Add 'pt' translation....* etc/news.scm: Add Portuguese translation of entry about pyproject-build-system. Signed-off-by: Florian Pelz <pelzflorian@pelzflorian.de> Thiago Jung Bauermann 2022-10-27news: Add entry for 'pyproject-build-system'....* etc/news.scm: Add entry. Co-authored-by: Florian Pelz <pelzflorian@pelzflorian.de> Co-authored-by: Julien Lepiller <julien@lepiller.eu> Marius Bakke 2022-10-17news: Add 'pt' translation....* etc/news.scm: Add Portuguese translation of entry about the new --emulate-fhs option. Signed-off-by: Julien Lepiller <julien@lepiller.eu> Thiago Jung Bauermann 2022-10-14news: Add 'de' translation....* etc/news.scm: Add German translation of '--emulate-fhs' entry. Florian Pelz 2022-10-13news: Add entry for 'guix shell --emulate-fhs'....* etc/news.scm: Add entry. Ludovic Courtès 2022-10-03news: Add 'pt' translation....* etc/news.scm: Add Portuguese translation of entry about the --with-source option being recursive. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Thiago Jung Bauermann 2022-10-01news: Add 'de' translation....* etc/news.scm: Add German translation of '--with-source' entry. Florian Pelz 2022-09-29news: Add entry for '--with-source'....* etc/news.scm: Add entry. Co-authored-by: Ludovic Courtès <ludo@gnu.org> Jesse Gibbons 2022-09-28news: Add 'pt' translation....* etc/news.scm: Add Portuguese translation of entries about WSL system images and about Guix System image API documentation. Signed-off-by: Mathieu Othacehe <othacehe@gnu.org> Thiago Jung Bauermann 2022-09-26news: Add another 'de' translation....* etc/news.scm: Add German translation of images API entry. Florian Pelz 2022-09-26news: Add 'de' translation....* etc/news.scm: Add German translation of WSL images entry. Florian Pelz 2022-09-25news: Add entry about image API documentation....* etc/news.scm: Add entry. Mathieu Othacehe 2022-09-25news: Add entry about WSL images....* etc/news.scm: Add entry. Mathieu Othacehe