aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm24
1 files changed, 12 insertions, 12 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index d1356931a1..f9e43583de 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -231,18 +231,18 @@ continuous display of high-volume data.")
(inputs
(list qtbase-5))
(arguments
- `(#:configure-flags
- '("-DCMAKE_CXX_FLAGS=-fPIC"
- "-DPHONON_BUILD_PHONON4QT5=ON")
- #:phases
- (modify-phases %standard-phases
- (add-before 'install 'patch-installdir
- (lambda* (#:key inputs outputs #:allow-other-keys)
- (let ((regex (string-append "(INSTALL DESTINATION \")"
- (assoc-ref inputs "qtbase"))))
- (substitute* "cmake_install.cmake"
- ((regex all dest)
- (string-append dest (assoc-ref outputs "out"))))))))))
+ (list #:configure-flags
+ #~'("-DCMAKE_CXX_FLAGS=-fPIC"
+ "-DPHONON_BUILD_PHONON4QT5=ON")
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-before 'install 'patch-installdir
+ (lambda* (#:key inputs outputs #:allow-other-keys)
+ (let ((regex (string-append "(INSTALL DESTINATION \")"
+ #$(this-package-input "qtbase"))))
+ (substitute* "cmake_install.cmake"
+ ((regex all dest)
+ (string-append dest #$output)))))))))
(home-page "https://community.kde.org/Phonon")
(synopsis "KDE's multimedia library")
(description "KDE's multimedia library.")