aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm23
1 files changed, 0 insertions, 23 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 83996f5e6b..13aabb577c 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -3276,29 +3276,6 @@ pytest report.")
"Python-pytest-catchlog is a pytest plugin to catch log messages.")
(license license:expat)))
-(define-public python-pytest-catchlog
- (package
- (name "python-pytest-catchlog")
- (version "1.2.2")
- (source
- (origin
- (method url-fetch)
- (uri (pypi-uri "pytest-catchlog" version ".zip"))
- (sha256
- (base32
- "1w7wxh27sbqwm4jgwrjr9c2gy384aca5jzw9c0wzhl0pmk2mvqab"))))
- (build-system python-build-system)
- (native-inputs
- (list unzip))
- (propagated-inputs
- (list python-pytest))
- (home-page "https://github.com/eisensheng/pytest-catchlog")
- (synopsis "Pytest plugin to catch log messages")
- (description
- "Python-pytest-catchlog is a pytest plugin to catch log messages. This is
-a fork of pytest-capturelog.")
- (license license:expat)))
-
(define-public python-nosexcover
(package
(name "python-nosexcover")
es: 'package->manifest-entry' preserves transformations by default.Ludovic Courtès Previously, transformations applied from a manifest (rather than via "guix install") would be lost. This change fixes that and simplifies things. Reported by zimoun at <https://lists.gnu.org/archive/html/guix-devel/2021-02/msg00153.html>. * guix/profiles.scm (default-properties): New procedure. (package->manifest-entry): Use it for #:properties. * guix/scripts/pack.scm (guix-pack)[with-transformations]: Remove. Remove caller. * guix/scripts/package.scm (transaction-upgrade-entry): Remove calls to 'manifest-entry-with-transformations'. * tests/guix-package.sh: Add test. * tests/transformations.scm ("options->transformation + package->manifest-entry"): New test. 2021-02-01guix package: Add '--export-manifest'.Ludovic Courtès * guix/scripts/package.scm (export-manifest): New procedure. (show-help, %options): Add '--export-manifest'. (process-query): Honor it. * guix/build/profiles.scm (build-profile): Mention it. * tests/guix-package.sh: Test it. * doc/guix.texi (Invoking guix package): Document it. 2020-10-02guix package: Re-apply package transformation when upgrading.Ludovic Courtès * guix/scripts/package.scm (transaction-upgrade-entry)[upgrade]: Add 'transform' parameter. Pass PKG through it. Use 'manifest-entry-with-transformations'. Call 'options->transformation' to get the transformation procedure. * tests/guix-package.sh: Add 'guix package -u' test. * tests/packages.scm ("transaction-upgrade-entry, transformation options preserved"): New test. * doc/guix.texi (Invoking guix package): Mention that transformations are preserved across upgrades. (Package Transformation Options): Likewise. 2020-10-02tests: Adjust to recent changes to the 'emacs' package.Ludovic Courtès Test regression introduced in f88fea0eaa5796303790450ee4543a6d7e61a06e. * tests/guix-package.sh: Add minor and patch levels in the version numbers of 'emacs-foo-bar' and 'emacs-foo-bar-patched'.