aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-io.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/crates-io.scm b/gnu/packages/crates-io.scm
index 58e6319588..5b17399322 100644
--- a/gnu/packages/crates-io.scm
+++ b/gnu/packages/crates-io.scm
@@ -1646,6 +1646,28 @@ fixed set of worker threads.")
(license (list license:asl2.0
license:expat))))
+(define-public rust-try-from
+ (package
+ (name "rust-try-from")
+ (version "0.3.2")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "try_from" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32
+ "12wdd4ja7047sd3rx70hv2056hyc8gcdllcx3a41g1rnw64kng98"))))
+ (build-system cargo-build-system)
+ (arguments
+ `(#:cargo-inputs
+ (("rust-cfg-if" ,rust-cfg-if))))
+ (home-page "https://github.com/derekjw/try_from")
+ (synopsis "TryFrom and TryInto traits for failable conversions")
+ (description
+ "TryFrom and TryInto traits for failable conversions that return a Result.")
+ (license license:expat)))
+
(define-public rust-typenum
(package
(name "rust-typenum")
td>Ludovic Courtès 2022-06-01doc: cookbook: Refer to the "Writing Manifests" manual node....Ludovic Courtès 2022-04-08doc: cookbook: Fix cross-reference to SICP....Ludovic Courtès 2022-04-08doc: cookbook: Fix cross-reference to the manual....Ludovic Courtès 2022-03-18doc: cookbook: Update Tor onion service name....Ludovic Courtès 2021-12-30doc: cookbook: Update custom kernel guide....Leo Famulari 2021-12-20doc: cookbook: Simplify inputs in examples....Ludovic Courtès 2021-10-12Merge remote-tracking branch 'origin/master' into core-updates-frozen.Mathieu Othacehe 2021-10-04doc: cookbook: Mention translations of the cookbook....Sarah Morgensen 2021-09-17Merge branch 'master' into core-updates-frozen...Marius Bakke 2021-09-08doc: add clarifications to Linode cookbook recipe...Grant Shangreaux 2021-09-07Merge branch 'master' into core-updates-frozenLudovic Courtès 2021-08-29Migrate to the new 'targets' field of bootloader-configuration....Maxim Cournoyer 2021-08-15Update copyright/name notices for Christine Lemmer-Webber....Christopher Lemmer Webber 2021-08-15doc: Fix typo....Ricardo Wurmus 2021-07-18Merge branch 'master' into core-updatesLudovic Courtès 2021-07-12doc: cookbook: Adjust example to simplified input style....Ludovic Courtès 2021-07-12doc: cookbook: Remove trailing #t from extended example....Ludovic Courtès 2021-07-07doc: Add guide showing auto-login on a specific TTY to the cookbook....Joshua Branson