aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ci.scm12
1 files changed, 6 insertions, 6 deletions
diff --git a/gnu/packages/ci.scm b/gnu/packages/ci.scm
index f4bd4ce000..86d99c9031 100644
--- a/gnu/packages/ci.scm
+++ b/gnu/packages/ci.scm
@@ -196,14 +196,14 @@ intended as a replacement for Hydra.")
(name "laminar")
(version "1.2")
(source
- (origin (method url-fetch)
- (uri (string-append "https://github.com/ohwgiles/laminar/archive/"
- version
- ".tar.gz"))
- (file-name (string-append name "-" version ".tar.gz"))
+ (origin (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ohwgiles/laminar")
+ (commit version)))
+ (file-name (git-file-name name version))
(sha256
(base32
- "0vcgpp8g67mlhqnyhkihxz9j5jz1pal79jrdhnmjl5ddbhkvji8i"))))
+ "1sg0kccp3nczkn2vxcsqv10vyvmjnhpaykc1nfhh55jyda4xzf9w"))))
(build-system cmake-build-system)
(arguments
`(#:tests? #f ; TODO Can't build tests
omes first. * guix/lint.scm (check-archival)[lookup-by-nar-hash]: New procedure. Call ‘lookup-by-nar-hash’ before the other lookup methods. * tests/lint.scm ("archival: content available") ("archival: content unavailable but disarchive available") ("archival: missing revision") ("archival: revision available"): Add a 404 response corresponding to the ‘lookup-external-id’ request. * tests/lint.scm ("archival: nar-sha256 extid available"): New test. Change-Id: I4a81d6e022a3b72e6484726549d7fbae627f8e73 Ludovic Courtès 2024-02-12swh: Add bindings for the “ExtID” API....This interface was deployed at archive.softwareheritage.org a few days ago. Our main use case will be looking up directories by “nar-sha256” hashes. * guix/swh.scm (<external-id>): New JSON-mapped record type. (lookup-external-id, lookup-directory-by-nar-hash): New procedures. * tests/swh.scm (%external-id): New variable. ("lookup-directory-by-nar-hash"): New test. Change-Id: Ib671c7798aeb6f8132ac78f2b06b9285da8e7bd5 Ludovic Courtès