aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/admin.scm16
1 files changed, 7 insertions, 9 deletions
diff --git a/gnu/packages/admin.scm b/gnu/packages/admin.scm
index 94c3a94765..927afb97b0 100644
--- a/gnu/packages/admin.scm
+++ b/gnu/packages/admin.scm
@@ -1052,9 +1052,7 @@ hostname.")
,@(if (%current-target-system)
'((add-before 'configure 'set-runtime-shell
(lambda* (#:key inputs #:allow-other-keys)
- (let ((shell (string-append
- (assoc-ref inputs "bash")
- "/bin/bash")))
+ (let ((shell (search-input-file inputs "/bin/bash")))
(setenv "RUNTIME_SHELL" shell)
(substitute* "configure.ac"
(("\\$SHELL")
@@ -1085,12 +1083,12 @@ hostname.")
(delete-file (string-append bin "/groups"))
(for-each delete-file (find-files man "^groups\\."))))))))
(inputs
- `(,@(if (target-hurd?)
- '()
- `(("linux-pam" ,linux-pam)))
- ,@(if (%current-target-system)
- `(("bash" ,bash-minimal))
- '())))
+ (append (if (target-hurd?)
+ '()
+ (list linux-pam))
+ (if (%current-target-system)
+ (list bash-minimal)
+ '())))
(home-page "https://github.com/shadow-maint/shadow")
(synopsis "Authentication-related tools such as passwd, su, and login")
(description