aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/version-control.scm34
1 files changed, 9 insertions, 25 deletions
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 86e30b0ba5..6c64f84779 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -1553,40 +1553,17 @@ specify a list of hooks you want and pre-commit manages the installation and
execution of any hook written in any language before every commit.")
(license license:expat)))
-(define (mercurial-patch name revision hash)
- (origin
- (method url-fetch)
- (uri (string-append "https://www.mercurial-scm.org/repo/hg/raw-rev/" revision))
- (file-name (string-append "mercurial-" name ".patch"))
- (sha256 (base32 hash))))
-
-(define %mercurial-patches
- (list
- ;; These three patches fixes compatibility with the updated gzip module
- ;; in Python 3.8.2: <https://bz.mercurial-scm.org/show_bug.cgi?id=6284>.
- (mercurial-patch "python-mtime" "6c36a521572edf3a79ee567b118469b3192037cc"
- "0bmm7y40r8s081ws2sjvn1v8kvyfan4a97jl0fhdh7yc2pzxlzqq")
- (mercurial-patch "indent-gzip" "a23b859ad17dd0a5b9bb37846b69b5e30f99c44c"
- "1spscv9dgqv38m7h1liki93ax6w97gxayg17fr7wr6acjdfccpr9")
- (mercurial-patch "python-gzip" "b7ca03dff14c63d64ad7bfa36a2d0a36a6b62253"
- "0p88ffhx0kk21ssrsb156ffhpcb7g8mkwwkmq49qpmbm5ag2paf0")
- ;; This fixes an incompatibility with os.isfile in Python 3.8:
- ;; <https://bz.mercurial-scm.org/show_bug.cgi?id=6287>.
- (mercurial-patch "os-isfile" "6a8738dc4a019da4c9df5c26961aa09d45ce1c68"
- "0lr069m12kzrkmr1pmhaxg5lxmdwxabsza61qp1i1q70g7sy8lvy")))
-
(define-public mercurial
(package
(name "mercurial")
- (version "5.3.1")
+ (version "5.5.1")
(source (origin
(method url-fetch)
(uri (string-append "https://www.mercurial-scm.org/"
"release/mercurial-" version ".tar.gz"))
- (patches %mercurial-patches)
(sha256
(base32
- "1nbjpzjrzgql4hrvslpxwbcgn885ikq6ba1yb4w6p78rw9nzkhgp"))))
+ "0x08yjs26j88kh1bvl2g3r24lnfc023ry3i1cxfq6haray6sv5ag"))))
(build-system python-build-system)
(arguments
`(#:phases
@@ -1615,6 +1592,13 @@ execution of any hook written in any language before every commit.")
;; not in 'guix environment -C' (even without /bin/sh)?
"test-nointerrupt.t"
+ ;; FIXME: This gets killed but does not receive an interrupt.
+ "test-commandserver.t"
+
+ ;; Only works when run in a hg-repo, not in an
+ ;; extracted tarball
+ "test-doctest.py"
+
;; TODO: the fqaddr() call fails in the build
;; container, causing these server tests to fail.
"test-hgwebdir.t"
es/textutils.scm, gnu/packages/time.scm, gnu/packages/tmux.scm, gnu/packages/tor.scm, gnu/packages/toys.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/virtualization.scm, gnu/packages/vlang.scm, gnu/packages/vnc.scm, gnu/packages/vpn.scm, gnu/packages/web-browsers.scm, gnu/packages/web.scm, gnu/packages/wireservice.scm, gnu/packages/wm.scm, gnu/packages/wxwidgets.scm, gnu/packages/xdisorg.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, tests/lint.scm: Remove trailing ".git" from 'git-reference' URL. Ludovic Courtès 2020-07-05gnu: rubber: Update to 1.5.1....* gnu/packages/tex.scm (rubber): Update to 1.5.1. [build-system]: Switch to python-build-system. [inputs]: Remove python-2 and which. [arguments]: Delete the build phase. Replace the install phase with a custom phase. Arun Isaac 2020-06-11gnu: lyx: Use qt-build-system....* gnu/packages/tex.scm (lyx)[build-system]: Switch to qt-build-system. [arguments]: Remove imported modules. Remove custom 'wrap-qt phase. Efraim Flashner 2020-06-11gnu: lyx: Don't install to custom directory....* gnu/packages/tex.scm (lyx)[arguments]: Adjust configure-flags to not add the version to the binary's suffix. Remove custom 'patch-desktop-file, 'setenv-check and 'install-symlink phases. Efraim Flashner 2020-06-11gnu: lyx: Update to 2.3.5.1....* gnu/packages/tex.scm (lyx): Update to 2.3.5.1. [arguments]: Remove 'fix-compilation-with-boost-1.69 phase. In 'patch-python phase patch more files, substitute with python3. Split 'setenv-check and create empty file after 'unpack. Efraim Flashner 2020-06-11gnu: lyx: Wrap binary.... Fixes <https://bugs.gnu.org/37147>. * gnu/packages/tex.scm (lyx)[arguments]: Import qt-utils. Add phase to wrap the lyx2.3 binary. Efraim Flashner 2020-06-02gnu: texlive-csquotes: Update source checksum....This package had not been adjusted for the TeX Live 2019 upgrade. Fixes <https://bugs.gnu.org/41660>. * gnu/packages/tex.scm (texlive-csquotes)[simple-texlive-package]: Update expected checksum. Marius Bakke 2020-06-01gnu: biber: Update to 2.12....Fixes <https://bugs.gnu.org/41400>. Reported by Mikhail Tsykalov <tsymsh@gmail.com>. This essentially reverts 40fd909e3ddee2c46a27a4fe92ed49d3e7ffb413. This is a followup to the TeX Live 2019 update in 85892948bd9fb5fcc3409a60204cc8b14a4eb030. * gnu/packages/tex.scm (biber): Update to 2.12. Ludovic Courtès 2020-04-30Merge branch 'master' into core-updates... Conflicts: gnu/local.mk gnu/packages/backup.scm gnu/packages/emacs-xyz.scm gnu/packages/guile.scm gnu/packages/lisp.scm gnu/packages/openldap.scm gnu/packages/package-management.scm gnu/packages/web.scm gnu/packages/xorg.scm Marius Bakke 2020-04-27gnu: Add texlive-inconsolata....* gnu/packages/tex.scm (texlive-inconsolata): New variable. Ricardo Wurmus 2020-04-26Merge branch 'master' into core-updatesMarius Bakke 2020-04-25gnu: texlive-latex-pdfx: Fix typo....* gnu/packages/tex.scm (texlive-latex-pdfx)[description]: Fix typo. Signed-off-by: Nicolas Goaziou <mail@nicolasgoaziou.fr> Matthew Kraai 2020-04-24Merge branch 'master' into core-updatesMarius Bakke 2020-04-24gnu: biber: Downgrade to 2.11....Biber 2.12 is incompatible with biblatex 3.11, which is what's currently packaged. This is a followup to 41a010875ba4108e666f11fc111cf5bb5dcf5464. * gnu/packages/tex.scm (biber): Downgrade to 2.11. Ludovic Courtès 2020-04-24gnu: biber: Address test failures....* gnu/packages/patches/biber-sortinithash.patch: New file. * gnu/local.mk (dist_patch_DATA): Add it. * gnu/packages/tex.scm (biber)[source]: Use it. Ludovic Courtès 2020-04-24gnu: Add texlive-csquotes....* gnu/packages/tex.scm (texlive-csquotes): New variable. Ricardo Wurmus 2020-04-23gnu: Add texlive-marginnote....* gnu/packages/tex.scm (texlive-marginnote): New variable. Ricardo Wurmus 2020-04-08Merge branch 'master' into core-updates... Conflicts: etc/news.scm gnu/local.mk gnu/packages/check.scm gnu/packages/cross-base.scm gnu/packages/gimp.scm gnu/packages/java.scm gnu/packages/mail.scm gnu/packages/sdl.scm gnu/packages/texinfo.scm gnu/packages/tls.scm gnu/packages/version-control.scm Marius Bakke 2020-04-04gnu: rubber: Make some inputs native....* gnu/packages/tex.scm (rubber)[inputs]: Move texinfo from here... [native-inputs]: ...to this new field. Signed-off-by: Danny Milosavljevic <dannym@scratchpost.org> Vincent Legoll