aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/freedesktop.scm41
1 files changed, 41 insertions, 0 deletions
diff --git a/gnu/packages/freedesktop.scm b/gnu/packages/freedesktop.scm
index a965f4242d..61d959e03f 100644
--- a/gnu/packages/freedesktop.scm
+++ b/gnu/packages/freedesktop.scm
@@ -424,6 +424,47 @@ inappropriate content.")
method framework.")
(license license:lgpl2.1+)))
+(define-public maliit-keyboard
+ (package
+ (name "maliit-keyboard")
+ (version "2.3.1")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/maliit/keyboard")
+ (commit version)))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0g89lckl4wzwamc89hs8871fbiyrsjwzk5b6ic4vhc4d1clyqzaw"))))
+ (build-system cmake-build-system)
+ (arguments
+ (list #:tests? #f
+ #:phases #~(modify-phases %standard-phases
+ (add-after 'install 'install-schemas
+ (lambda* (#:key source outputs #:allow-other-keys)
+ (with-directory-excursion (string-append #$output
+ "/share/glib-2.0/schemas")
+ (invoke "glib-compile-schemas" ".")))))))
+ (native-inputs (list extra-cmake-modules pkg-config gettext-minimal
+ `(,glib "bin")))
+ (inputs (list hunspell
+ glib
+ libchewing
+ libpinyin
+ maliit-framework
+ presage
+ qtbase-5
+ qtdeclarative-5
+ qtmultimedia-5
+ qtquickcontrols2-5))
+ (home-page "https://github.com/maliit/keyboard")
+ (synopsis "Maliit Keyboard")
+ (description
+ "This package provides virtual keyboard for Wayland and X11
+display servers. It supports many different languages and emoji.")
+ (license license:gpl3+)))
+
(define-public xdg-utils
(package
(name "xdg-utils")