aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gcc.scm3
1 files changed, 3 insertions, 0 deletions
diff --git a/gnu/packages/gcc.scm b/gnu/packages/gcc.scm
index 419e2c9cbf..8465859c24 100644
--- a/gnu/packages/gcc.scm
+++ b/gnu/packages/gcc.scm
@@ -436,6 +436,9 @@ using compilers other than GCC."
(define-public gfortran
(custom-gcc gcc "gfortran" '("fortran")))
+(define-public gfortran-5
+ (custom-gcc gcc-5 "gfortran" '("fortran")))
+
(define-public gccgo-4.8
(custom-gcc gcc-4.8 "gccgo" '("go")
;; Suppress the separate "lib" output, because otherwise the
' class='logmsg'> * gnu/packages/aux-files/run-in-namespace.c (exec_with_proot): New function. (main): When 'clone' fails, call 'rm_rf'. [PROOT_PROGRAM]: When 'clone' fails, call 'exec_with_proot'. * guix/scripts/pack.scm (wrapped-package): Add #:proot?. [proot]: New procedure. [build]: Compile with -DPROOT_PROGRAM when PROOT? is true. * guix/scripts/pack.scm (%options): Set the 'relocatable?' value to 'proot when "-R" is passed several times. (guix-pack): Pass #:proot? to 'wrapped-package'. * tests/guix-pack-relocatable.sh: Use "-RR" on Intel systems that lack user namespace support. * doc/guix.texi (Invoking guix pack): Document -RR. 2018-11-06pack: Add test for '--relocatable'.Ludovic Courtès * tests/guix-pack-relocatable.sh: New file. * Makefile.am (SH_TESTS): Add it.