aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/rust-apps.scm20
1 files changed, 9 insertions, 11 deletions
diff --git a/gnu/packages/rust-apps.scm b/gnu/packages/rust-apps.scm
index bc9776e773..7d85cb19e1 100644
--- a/gnu/packages/rust-apps.scm
+++ b/gnu/packages/rust-apps.scm
@@ -2494,19 +2494,20 @@ background agent taking care of maintaining the necessary state.")
(define-public rust-cargo
(package
(name "rust-cargo")
- (version "0.77.0")
+ (version "0.78.0")
(source
(origin
(method url-fetch)
(uri (crate-uri "cargo" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "1csj4mpzdjh26ah2vahxc0y6r31gbrv479kv5jm49larvrdrwfaa"))))
+ (base32 "1fzsljg3imn8naxniqw5pxdidq0fglgxjcpfjh0q9dxycmzlzaj0"))))
(build-system cargo-build-system)
(arguments
`(#:tests? #f ; unresolved import `cargo_test_support`
#:cargo-inputs
- (("rust-anstream" ,rust-anstream-0.6)
+ (("rust-annotate-snippets" ,rust-annotate-snippets-0.10)
+ ("rust-anstream" ,rust-anstream-0.6)
("rust-anstyle" ,rust-anstyle-1)
("rust-anyhow" ,rust-anyhow-1)
("rust-base64" ,rust-base64-0.21)
@@ -2517,9 +2518,10 @@ background agent taking care of maintaining the necessary state.")
("rust-cargo-credential-wincred" ,rust-cargo-credential-wincred-0.4)
("rust-cargo-platform" ,rust-cargo-platform-0.1)
("rust-cargo-util" ,rust-cargo-util-0.2)
+ ("rust-cargo-util-schemas" ,rust-cargo-util-schemas-0.2)
("rust-clap" ,rust-clap-4)
("rust-color-print" ,rust-color-print-0.3)
- ("rust-crates-io" ,rust-crates-io-0.39)
+ ("rust-crates-io" ,rust-crates-io-0.40)
("rust-curl" ,rust-curl-0.4)
("rust-curl-sys" ,rust-curl-sys-0.4)
("rust-filetime" ,rust-filetime-0.2)
@@ -2527,8 +2529,8 @@ background agent taking care of maintaining the necessary state.")
("rust-flate2" ,rust-flate2-1)
("rust-git2" ,rust-git2-0.18)
("rust-git2-curl" ,rust-git2-curl-0.19)
- ("rust-gix" ,rust-gix-0.56)
- ("rust-gix-features" ,rust-gix-features-0.35)
+ ("rust-gix" ,rust-gix-0.57)
+ ("rust-gix-features" ,rust-gix-features-0.37)
("rust-glob" ,rust-glob-0.3)
("rust-hex" ,rust-hex-0.4)
("rust-hmac" ,rust-hmac-0.12)
@@ -2549,21 +2551,18 @@ background agent taking care of maintaining the necessary state.")
("rust-os-info" ,rust-os-info-3)
("rust-pasetors" ,rust-pasetors-0.6)
("rust-pathdiff" ,rust-pathdiff-0.2)
- ("rust-pulldown-cmark" ,rust-pulldown-cmark-0.9)
("rust-rand" ,rust-rand-0.8)
("rust-regex" ,rust-regex-1)
("rust-rusqlite" ,rust-rusqlite-0.30)
- ("rust-rustfix" ,rust-rustfix-0.7)
+ ("rust-rustfix" ,rust-rustfix-0.8)
("rust-semver" ,rust-semver-1)
("rust-serde" ,rust-serde-1)
("rust-serde-untagged" ,rust-serde-untagged-0.1)
- ("rust-serde-value" ,rust-serde-value-0.7)
("rust-serde-ignored" ,rust-serde-ignored-0.1)
("rust-serde-json" ,rust-serde-json-1)
("rust-sha1" ,rust-sha1-0.10)
("rust-shell-escape" ,rust-shell-escape-0.1)
("rust-supports-hyperlinks" ,rust-supports-hyperlinks-2)
- ("rust-syn" ,rust-syn-2)
("rust-tar" ,rust-tar-0.4)
("rust-tempfile" ,rust-tempfile-3)
("rust-time" ,rust-time-0.3)
@@ -2573,7 +2572,6 @@ background agent taking care of maintaining the necessary state.")
("rust-tracing-subscriber" ,rust-tracing-subscriber-0.3)
("rust-unicase" ,rust-unicase-2)
("rust-unicode-width" ,rust-unicode-width-0.1)
- ("rust-unicode-xid" ,rust-unicode-xid-0.2)
("rust-url" ,rust-url-2)
("rust-walkdir" ,rust-walkdir-2)
("rust-windows-sys" ,rust-windows-sys-0.52))
gnu: passt: Update to 2024_03_20.71dd405....Tomas Volf 2024-05-21gnu: conmon: Update to 2.1.11....Tomas Volf 2024-05-21gnu: podman: Update to 5.0.2....Tomas Volf 2024-05-21gnu: podman: Drop obsolete comment....Tomas Volf 2024-05-21gnu: crun: Update to 1.15....Tomas Volf 2024-05-13gnu: slirp4netns: Update to 1.3.0....Tomas Volf 2024-03-22gnu: distrobox: Fix dependency usage....Jean-Pierre De Jesus DIAZ 2024-03-22gnu: distrobox: Update to 1.7.0....Jean-Pierre De Jesus DIAZ 2024-03-22gnu: Add gvisor-tap-vsock....Tomas Volf 2024-03-13gnu: cni-plugins: Update to 1.4.1....Tomas Volf 2024-03-02gnu: podman: Update to 4.9.3....Tomas Volf 2024-03-02gnu: Add passt....Tomas Volf 2024-02-14gnu: crun: Adjust package ideation....Sharlatan Hellseher 2024-02-14gnu: crun: Update to 1.14.1....Tomas Volf 2024-02-14gnu: slirp4netns: Update to 1.2.3....Tomas Volf 2023-10-13gnu: distrobox: Update to 1.5.0.2....Ricardo Wurmus