aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/attr.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/attr.scm b/gnu/packages/attr.scm
index 3237376d40..a062125303 100644
--- a/gnu/packages/attr.scm
+++ b/gnu/packages/attr.scm
@@ -30,14 +30,14 @@
(define-public attr
(package
(name "attr")
- (version "2.4.48")
+ (version "2.5.1")
(source (origin
(method url-fetch)
(uri (string-append "mirror://savannah/attr/attr-"
version ".tar.gz"))
(sha256
(base32
- "1rr4adzwax4bzr2c00f06zcsljv5y6p9wymz1g89ww7cb2rp5bay"))))
+ "1y6sibbkrcjygv8naadnsg6xmsqwfh6cwrqk01l0v2i5kfacdqds"))))
(build-system gnu-build-system)
(arguments
`(#:phases
@@ -57,8 +57,7 @@
;; extended attributes, and we wish to allow Guix to be built
;; on such systems.
(unless target
- (system* "make" "tests" "-C" "test"))
- #t)))))
+ (system* "make" "tests" "-C" "test")))))))
(inputs
;; Perl is needed to run tests; remove it from cross builds.
(if (%current-target-system)
tem.scm?id=dd8356e3c6a27b4d6655a3d0aea2d52410f6edc4'>hydra: Use short timeouts for the QEMU jobs and system tests....These builds shouldn't take too long. Sometimes the guest kernel crashes and the VM gets stuck; we should be able to terminate those jobs quickly. * build-aux/hydra/gnu-system.scm (qemu-jobs)[->alist]: Add 'max-silent-time' and 'timeout'. (system-test-jobs)[test->thunk]: Likewise. Ludovic Courtès 2018-12-09hydra: Increase image sizes for USB image and Flash image....* build-aux/hydra/gnu-system.scm (qemu-jobs) <usb-image>: Increase from 1024 MiB to 1500 MiB. <flash-image>: Increase from 1024 MiB to 1500 MiB. Danny Milosavljevic