aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/local.mk1
-rw-r--r--gnu/packages/patches/ganeti-pyyaml-compat.patch41
-rw-r--r--gnu/packages/virtualization.scm1
3 files changed, 43 insertions, 0 deletions
diff --git a/gnu/local.mk b/gnu/local.mk
index a44815bdbb..2a68d45717 100644
--- a/gnu/local.mk
+++ b/gnu/local.mk
@@ -1084,6 +1084,7 @@ dist_patch_DATA = \
%D%/packages/patches/ganeti-disable-version-symlinks.patch \
%D%/packages/patches/ganeti-haskell-compat.patch \
%D%/packages/patches/ganeti-haskell-pythondir.patch \
+ %D%/packages/patches/ganeti-pyyaml-compat.patch \
%D%/packages/patches/ganeti-shepherd-master-failover.patch \
%D%/packages/patches/ganeti-shepherd-support.patch \
%D%/packages/patches/ganeti-sphinx-compat.patch \
diff --git a/gnu/packages/patches/ganeti-pyyaml-compat.patch b/gnu/packages/patches/ganeti-pyyaml-compat.patch
new file mode 100644
index 0000000000..2f74e48a82
--- /dev/null
+++ b/gnu/packages/patches/ganeti-pyyaml-compat.patch
@@ -0,0 +1,41 @@
+Add Loader argument to 'yaml.load' invocations as required by PyYAML 6.0.
+
+Submitted upstream:
+
+ https://github.com/ganeti/ganeti/pull/1668
+
+diff --git a/qa/qa_utils.py b/qa/qa_utils.py
+index da485df48..27428e685 100644
+--- a/qa/qa_utils.py
++++ b/qa/qa_utils.py
+@@ -450,7 +450,7 @@ def GetObjectInfo(infocmd):
+ master = qa_config.GetMasterNode()
+ cmdline = utils.ShellQuoteArgs(infocmd)
+ info_out = GetCommandOutput(master.primary, cmdline)
+- return yaml.load(info_out)
++ return yaml.load(info_out, Loader=yaml.SafeLoader)
+
+
+ def UploadFile(node, src):
+diff --git a/test/py/ganeti.cli_unittest.py b/test/py/ganeti.cli_unittest.py
+index 9cc980afa..242aac9fd 100755
+--- a/test/py/ganeti.cli_unittest.py
++++ b/test/py/ganeti.cli_unittest.py
+@@ -1141,14 +1141,15 @@ class TestFormatPolicyInfo(unittest.TestCase):
+ self._RenameDictItem(minmax, key, keyparts[0])
+ self.assertTrue(constants.IPOLICY_DTS in parsed)
+ parsed[constants.IPOLICY_DTS] = yaml.load("[%s]" %
+- parsed[constants.IPOLICY_DTS])
++ parsed[constants.IPOLICY_DTS],
++ Loader=yaml.SafeLoader)
+
+ @staticmethod
+ def _PrintAndParsePolicy(custom, effective, iscluster):
+ formatted = cli.FormatPolicyInfo(custom, effective, iscluster)
+ buf = StringIO()
+ cli._SerializeGenericInfo(buf, formatted, 0)
+- return yaml.load(buf.getvalue())
++ return yaml.load(buf.getvalue(), Loader=yaml.SafeLoader)
+
+ def _PrintAndCheckParsed(self, policy):
+ parsed = self._PrintAndParsePolicy(policy, NotImplemented, True)
diff --git a/gnu/packages/virtualization.scm b/gnu/packages/virtualization.scm
index a058e59f6b..1f71f079c2 100644
--- a/gnu/packages/virtualization.scm
+++ b/gnu/packages/virtualization.scm
@@ -561,6 +561,7 @@ firmware blobs. You can
"ganeti-sphinx-compat.patch"
"ganeti-haskell-compat.patch"
"ganeti-haskell-pythondir.patch"
+ "ganeti-pyyaml-compat.patch"
"ganeti-disable-version-symlinks.patch"))))
(build-system gnu-build-system)
(arguments
t;/static/img/pkg-icon-doc_20x12.svg\" alt=\"\">Documentation</h2>\n <div class=\"Documentation js-documentation\">\n <div class=\"Documentation-content js-docContent\">\n <section class=\"Documentation-overview\">\n <h3 tabindex=\"-1\" id=\"pkg-overview\" class=\"Documentation-overviewHeader\">Overview <a href=\"#pkg-overview\">¶</a></h3>\n <div role=\"navigation\" aria-label=\"Table of Contents\">\n <ul class=\"Documentation-toc\"></ul>\n </div>\n <p>Package check is a rich testing extension for Go's testing package.</p>\n <p>For details about the project, see:</p>\n <pre><a href=\"http://labix.org/gocheck\">http://labix.org/gocheck</a>\n</pre>\n </section>\n <h3 tabindex=\"-1\" id=\"pkg-constants\" class=\"Documentation-constantsHeader\">Constants <a href=\"#pkg-constants\">¶</a></h3>\n </div>\n </div>\n </div>\n </div>\n </div>\n </div>\n </div>\n</body>\n</html>\n") (pkg.go.dev-licence "<!DOCTYPE html>\n<html lang=\"en\">\n<meta charset=\"utf-8\">\n<meta http-equiv=\"X-UA-Compatible\" content=\"IE=edge\">\n<body class=\"Site Site--wide Site--redesign\">\n <div class=\"Unit-content\" role=\"main\">\n <section class=\"License\" id=\"lic-0\">\n <h2><div id=\"#lic-0\">BSD-2-Clause</div></h2>\n <p>This is not legal advice. <a href=\"/license-policy\">Read disclaimer.</a></p>\n <pre class=\"License-contents\">Gocheck - A rich testing framework for Go\n \nCopyright line\n\nAll rights reserved.\n\nRedistribution and use in source and binary forms, with or without\nmodification, are permitted provided that the following conditions are met: \n\n1. Redistributions of source code must retain the above copyright notice, this\n list of conditions and the following disclaimer. \n2. Redistributions in binary form must reproduce the above copyright notice,\n this list of conditions and the following disclaimer in the documentation\n and/or other materials provided with the distribution. \n\nTHIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS &#34;AS IS&#34; AND\nANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED\nWARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE\nDISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR CONTRIBUTORS BE LIABLE FOR\nANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES\n(INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;\nLOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND\nON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT\n(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS\nSOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.\n</pre>\n </section>\n <div class=\"License-source\">Source: github.com/go-check/check@v0.0.0-20201128035030-22ab2dfb190c/LICENSE</div>\n </div>\n </div>\n")) `(("https://proxy.golang.org/github.com/go-check/check/@v/v0.0.0-20201130134442-10cb98267c6c.mod" . ,go.mod) ("https://proxy.golang.org/github.com/go-check/check/@latest" . ,version) ("https://proxy.golang.org/github.com/go-check/check/@v/v0.0.0-20201130134442-10cb98267c6c.info" . ,go.info) ("https://github.com/go-check/check?go-get=1" . ,go-get) ("https://pkg.go.dev/github.com/go-check/check" . ,pkg.go.dev) ("https://pkg.go.dev/github.com/go-check/check?tab=licenses" . ,pkg.go.dev-licence) ("https://proxy.golang.org/github.com/go-check/check/@v/list" . "")))) (test-begin "go") ;;; Unit tests for go build-system (test-equal "go-version basic" "v1.0.2" (go-version->git-ref "v1.0.2")) (test-equal "go-version with embedded git-ref" "65e3620a7ae7" (go-version->git-ref "v0.0.0-20190821162956-65e3620a7ae7")) (test-equal "go-version with complex embedded git-ref" "daa7c04131f5" (go-version->git-ref "v1.2.4-0.20191109021931-daa7c04131f5")) (test-assert "go-pseudo-version? multi-digit version number" (go-pseudo-version? "v1.23.1-0.20200526195155-81db48ad09cc")) (test-assert "go-pseudo-version? semantic version with rc" (go-pseudo-version? "v1.4.0-rc.4.0.20200313231945-b860323f09d0")) ;;; Unit tests for (guix import go) (test-equal "go-path-escape" "github.com/!azure/!avere" ((@@ (guix import go) go-path-escape) "github.com/Azure/Avere")) ;; We define a function for all similar tests with different go.mod files (define (testing-parse-mod name expected input) (define (inf? p1 p2) (string<? (car p1) (car p2))) (test-equal name (sort expected inf?) (sort (go.mod-requirements (parse-go.mod input)) inf?))) (testing-parse-mod "parse-go.mod-simple" '(("good/thing" "v1.4.5") ("new/thing/v2" "v2.3.4") ("other/thing" "v1.0.2")) fixture-go-mod-simple) (testing-parse-mod "parse-go.mod-with-block" '(("A" "v1") ("B" "v1.0.0") ("C" "v1.0.0") ("D" "v1.2.3") ("E" "dev")) fixture-go-mod-with-block) (testing-parse-mod "parse-go.mod-complete" '(("github.com/corp/arbitrary-repo" "v0.0.2") ("quoted.example.com/abitrary/repo" "v0.0.2") ("one.example.com/abitrary/repo" "v1.1.111") ("hub.jazz.net/git/user/project/sub/directory" "v1.1.19") ("hub.jazz.net/git/user/project" "v1.1.18") ("launchpad.net/~user/project/branch/sub/directory" "v1.1.17") ("launchpad.net/~user/project/branch" "v1.1.16") ("launchpad.net/project/series/sub/directory" "v1.1.15") ("launchpad.net/project/series" "v1.1.14") ("launchpad.net/project" "v1.1.13") ("bitbucket.org/user/project/sub/directory" "v1.11.21") ("bitbucket.org/user/project" "v1.11.20") ("k8s.io/kubernetes/subproject" "v1.1.101") ("github.com/user/project/sub/directory" "v1.1.12") ("github.com/user/project" "v1.1.11") ("github.com/go-check/check" "v0.0.0-20140225173054-eb6ee6f84d0a")) fixture-go-mod-complete) (test-equal "parse-go.mod: simple" `((module (module-path "my/thing")) (go (version "1.12")) (require (module-path "other/thing") (version "v1.0.2")) (require (module-path "new/thing/v2") (version "v2.3.4")) (exclude (module-path "old/thing") (version "v1.2.3")) (replace (original (module-path "bad/thing") (version "v1.4.5")) (with (module-path "good/thing") (version "v1.4.5")))) (parse-go.mod fixture-go-mod-simple)) (test-equal "parse-go.mod: comments and unparsable lines" `((module (module-path "my/thing")) (go (version "1.12") (comment "avoid feature X")) (require (module-path "other/thing") (version "v1.0.2")) (comment "Security issue: CVE-XXXXX") (exclude (module-path "old/thing") (version "v1.2.3")) (unknown "new-directive another/thing yet-another/thing") (replace (original (module-path "bad/thing") (version "v1.4.5")) (with (module-path "good/thing") (version "v1.4.5"))) (comment "Unparseable") (unknown "bad/thing [v1.4.5, v1.9.7] => good/thing v2.0.0")) (parse-go.mod fixture-go-mod-unparsable)) (test-equal "parse-go.mod: retract" `((retract (version "v0.9.1")) (retract (version "v1.9.2")) (retract (range (version "v1.0.0") (version "v1.7.9")))) (parse-go.mod fixture-go-mod-retract)) (test-equal "parse-go.mod: raw strings and quoted strings" `((require (module-path "example.com/\"some-repo\"") (version "v1.9.3")) (require (module-path "example.com/\"another.repo\"") (version "v1.0.0")) (require (module-path "example.com/special!repo") (version "v9.3.1")) (replace (original (module-path "example.com/\"some-repo\"")) (with (module-path "launchpad.net/some-repo") (version "v1.9.3"))) (replace (original (module-path "example.com/\"another.repo\"")) (with (module-path "launchpad.net/another-repo") (version "v1.0.0")))) (parse-go.mod fixture-go-mod-strings)) (test-equal "parse-go.mod: complete" `((module (module-path "M")) (go (version "1.13")) (replace (original (module-path "github.com/myname/myproject/myapi")) (with (file-path "./api"))) (replace (original (module-path "github.com/mymname/myproject/thissdk")) (with (file-path "../sdk"))) (replace (original (module-path "launchpad.net/gocheck")) (with (module-path "github.com/go-check/check") (version "v0.0.0-20140225173054-eb6ee6f84d0a"))) (require (module-path "github.com/user/project") (version "v1.1.11")) (require (module-path "github.com/user/project/sub/directory") (version "v1.1.12")) (require (module-path "bitbucket.org/user/project") (version "v1.11.20")) (require (module-path "bitbucket.org/user/project/sub/directory") (version "v1.11.21")) (require (module-path "launchpad.net/project") (version "v1.1.13")) (require (module-path "launchpad.net/project/series") (version "v1.1.14")) (require (module-path "launchpad.net/project/series/sub/directory") (version "v1.1.15")) (require (module-path "launchpad.net/~user/project/branch") (version "v1.1.16")) (require (module-path "launchpad.net/~user/project/branch/sub/directory") (version "v1.1.17")) (require (module-path "hub.jazz.net/git/user/project") (version "v1.1.18")) (require (module-path "hub.jazz.net/git/user/project/sub/directory") (version "v1.1.19")) (require (module-path "k8s.io/kubernetes/subproject") (version "v1.1.101")) (require (module-path "one.example.com/abitrary/repo") (version "v1.1.111")) (require (module-path "two.example.com/abitrary/repo") (version "v0.0.2")) (require (module-path "quoted.example.com/abitrary/repo") (version "v0.0.2")) (replace (original (module-path "two.example.com/abitrary/repo")) (with (module-path "github.com/corp/arbitrary-repo") (version "v0.0.2"))) (replace (original (module-path "golang.org/x/sys")) (with (module-path "golang.org/x/sys") (version "v0.0.0-20190813064441-fde4db37ae7a")) (comment "pinned to release-branch.go1.13")) (replace (original (module-path "golang.org/x/tools")) (with (module-path "golang.org/x/tools") (version "v0.0.0-20190821162956-65e3620a7ae7")) (comment "pinned to release-branch.go1.13"))) (parse-go.mod fixture-go-mod-complete)) ;;; End-to-end tests for (guix import go) (define (mock-http-fetch testcase) (lambda (url . rest) (let ((body (assoc-ref testcase url))) (if body (open-input-string body) (error "mocked http-fetch Unexpected URL: " url))))) (define (mock-http-get testcase) (lambda (url . rest) (let ((body (assoc-ref testcase url)) (response-header (build-response #:version '(1 . 1) #:code 200 #:reason-phrase "Ok" #:headers `( (content-type text/html (charset . "utf-8")) (date . ,(make-date 0 10 58 12 6 3 2021 0)) (transfer-encoding (chunked))) #:port #f #:validate-headers? #t))) (if body (values response-header body) (error "mocked http-get Unexpected URL: " url))))) (test-equal "go-module->guix-package" '(package (name "go-github-com-go-check-check") (version "0.0.0-20201130134442-10cb98267c6c") (source (origin (method git-fetch) (uri (git-reference (url "https://github.com/go-check/check") (commit (go-version->git-ref version)))) (file-name (git-file-name name version)) (sha256 (base32 "0sjjj9z1dhilhpc8pq4154czrb79z9cm044jvn75kxcjv6v5l2m5")))) (build-system go-build-system) (arguments (list #:import-path "github.com/go-check/check")) (propagated-inputs (list go-github-com-kr-pretty)) (home-page "https://github.com/go-check/check") (synopsis "Instructions") (description "Package check is a rich testing extension for Go's testing \ package.") (license license:bsd-2)) ;; Replace network resources with sample data. (call-with-temporary-directory (lambda (checkout) (mock ((web client) http-get (mock-http-get fixtures-go-check-test)) (mock ((guix http-client) http-fetch (mock-http-fetch fixtures-go-check-test)) (mock ((guix git) update-cached-checkout (lambda* (url #:key ref) ;; Return an empty directory and its hash. (values checkout (nix-base32-string->bytevector "0sjjj9z1dhilhpc8pq4154czrb79z9cm044jvn75kxcjv6v5l2m5") #f))) (go-module->guix-package* "github.com/go-check/check"))))))) (test-end "go")