aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/base.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/base.scm b/gnu/packages/base.scm
index c7e7585647..b3f54798c4 100644
--- a/gnu/packages/base.scm
+++ b/gnu/packages/base.scm
@@ -405,7 +405,15 @@ differences.")
(lambda _
(substitute* "tests/large-subopt"
(("^#!.*" all)
- (string-append all "exit 77;\n"))))))
+ (string-append all "exit 77;\n")))
+ #$@(if (system-hurd64?)
+ #~((substitute*
+ ;; These tests hang.
+ '("gnulib-tests/test-c-stack.sh"
+ "gnulib-tests/test-c-stack2.sh")
+ (("^#!.*" all)
+ (string-append all "exit 77;\n"))))
+ #~()))))
#~%standard-phases)))
(native-inputs (list perl))
(synopsis "Comparing and merging files")