aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/jami.scm4
-rw-r--r--gnu/packages/video.scm10
2 files changed, 6 insertions, 8 deletions
diff --git a/gnu/packages/jami.scm b/gnu/packages/jami.scm
index 4e8d36ca96..65607249ba 100644
--- a/gnu/packages/jami.scm
+++ b/gnu/packages/jami.scm
@@ -349,7 +349,7 @@
(define-public ffmpeg-jami
(package
- (inherit ffmpeg-5)
+ (inherit ffmpeg)
(name "ffmpeg-jami")
;; XXX: Use a slightly older version, otherwise the
;; 'libopusdec-enable-FEC' patch doesn't apply.
@@ -363,7 +363,7 @@
"0yq0jcdc4qm5znrzylj3dsicrkk2n3n8bv28vr0a506fb7iglbpg"))))
(outputs '("out" "debug"))
(arguments
- (substitute-keyword-arguments (package-arguments ffmpeg-5)
+ (substitute-keyword-arguments (package-arguments ffmpeg)
((#:configure-flags _ '())
#~(cons* "--disable-static"
"--enable-shared"
diff --git a/gnu/packages/video.scm b/gnu/packages/video.scm
index 93a2425932..064ebb07d3 100644
--- a/gnu/packages/video.scm
+++ b/gnu/packages/video.scm
@@ -1576,7 +1576,7 @@ These tools require a supported graphics chip, driver, and VA-API back end to
operate properly.")
(license license:expat)))
-(define-public ffmpeg-5
+(define-public ffmpeg
(package
(name "ffmpeg")
(version "5.1.2")
@@ -1772,7 +1772,7 @@ audio/video codec library.")
(define-public ffmpeg-4
(package
- (inherit ffmpeg-5)
+ (inherit ffmpeg)
(version "4.4.2")
(source (origin
(method url-fetch)
@@ -1781,10 +1781,10 @@ audio/video codec library.")
(sha256
(base32
"14xadxm1yaamp216nq09xwasxg5g133v86dbb33mdg5di1zrlhdg"))))
- (inputs (modify-inputs (package-inputs ffmpeg-5)
+ (inputs (modify-inputs (package-inputs ffmpeg)
(replace "sdl2" sdl2-2.0)))
(arguments
- (substitute-keyword-arguments (package-arguments ffmpeg-5)
+ (substitute-keyword-arguments (package-arguments ffmpeg)
((#:configure-flags flags ''())
#~(cons "--enable-avresample" #$flags))))))
@@ -1863,8 +1863,6 @@ audio/video codec library.")
(inputs (modify-inputs (package-inputs ffmpeg-3.4)
(delete "libwebp")))))
-(define-public ffmpeg ffmpeg-5)
-
(define-public ffmpeg-for-stepmania
(hidden-package
(package