aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gtk.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/gtk.scm b/gnu/packages/gtk.scm
index 52ee8575cd..2c1a9e84fc 100644
--- a/gnu/packages/gtk.scm
+++ b/gnu/packages/gtk.scm
@@ -593,7 +593,7 @@ highlighting and other features typical of a source code editor.")
(arguments
`(#:meson ,meson-0.55
#:glib-or-gtk? #t ; To wrap binaries and/or compile schemas
- #:configure-flags '("-Dinstalled_tests=false")
+ #:configure-flags '("-Dinstalled_tests=false" "-Djasper=true")
#:phases
(modify-phases %standard-phases
;; The slow tests take longer than the specified timeout.
@@ -611,7 +611,8 @@ highlighting and other features typical of a source code editor.")
;; Used for testing and required at runtime.
("shared-mime-info" ,shared-mime-info)))
(inputs
- `(("libjpeg" ,libjpeg-turbo)
+ `(("jasper" ,jasper)
+ ("libjpeg" ,libjpeg-turbo)
("libpng" ,libpng)
("libtiff" ,libtiff)))
(native-inputs
dmap.cfg" input name. Nicolas Goaziou 2023-06-17gnu: Use target-hurd?, system-hurd? instead of hurd-target?, hurd-system?....* gnu/packages/hurd.scm (hurd-target?): Remove. (hurd-system?): Move to... * guix/utils.scm (system-hurd?): ...here. * gnu/packages/*: Update all users, removing (gnu packages hurd) include where now unused. Janneke Nieuwenhuizen 2023-04-21gnu: po4a: Remove patch-docbook-xml phase....* gnu/packages/gettext.scm (po4a) [arguments]: Remove patch-docbook-xml phase. Remove trailing #t. Use gexps. [native-inputs]: Remove labels. Maxim Cournoyer 2023-03-20Merge remote-tracking branch 'origin/master' into core-updatesAndreas Enge 2023-03-12gnu: mdpo: Remove python-pre-commit....* gnu/packages/gettext.scm (mdpo)[native-inputs]: Remove python-pre-commit. Signed-off-by: Lars-Dominik Braun <lars@6xq.net> Antero Mejr 2023-02-26gnu: gettext: Remove input label....* gnu/packages/gettext.scm (gnu-gettext)[native-inputs]: Remove label. Ludovic Courtès 2023-01-30Merge remote-tracking branch 'origin/master' into core-updates... Conflicts: doc/guix.texi gnu/local.mk gnu/packages/admin.scm gnu/packages/base.scm gnu/packages/chromium.scm gnu/packages/compression.scm gnu/packages/databases.scm gnu/packages/diffoscope.scm gnu/packages/freedesktop.scm gnu/packages/gnome.scm gnu/packages/gnupg.scm gnu/packages/guile.scm gnu/packages/inkscape.scm gnu/packages/llvm.scm gnu/packages/openldap.scm gnu/packages/pciutils.scm gnu/packages/ruby.scm gnu/packages/samba.scm gnu/packages/sqlite.scm gnu/packages/statistics.scm gnu/packages/syndication.scm gnu/packages/tex.scm gnu/packages/tls.scm gnu/packages/version-control.scm gnu/packages/xml.scm guix/build-system/copy.scm guix/scripts/home.scm Efraim Flashner 2023-01-03gnu: po4a: Update to 0.68...The phase do-not-override-PERL5LIB is removed since it was fixed in po4a v0.63. https://github.com/mquinson/po4a/blob/0ab1670e50f0a72781e3d1de6ab9da0c2d71c646/NEWS#L366 bash-minimal is added to inputs since the wrap-program function is used. See also https://issues.guix.gnu.org/49327#80 The only regrettable thing is that only the SGML test failed, but I could not find the cause... Nevertheless, some previously failed tests are now passing. * gnu/packages/gettext.scm (po4a): Update to 0.68. Signed-off-by: Julien Lepiller <julien@lepiller.eu> gemmaro 2022-11-23gnu: gettext: Skip Gnulib tests that fail on GNU/Hurd....* gnu/packages/gettext.scm (gettext-minimal)[arguments]: In 'patch-tests' phase, arrange to not run 'test-tls'. Adjust 'XFAIL_TESTS' flag passed to #:make-flags. Ludovic Courtès 2022-05-28gnu: gettext-minimal: Fix build with new libunistring....* gnu/packages/gettext.scm (gettext-minimal)[source]: Add patch. * gnu/packages/patches/gettext-libunicode-update.patch: New file. * gnu/local.mk (dist_patch_DATA): Register it. Efraim Flashner