aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/libunwind.scm12
1 files changed, 8 insertions, 4 deletions
diff --git a/gnu/packages/libunwind.scm b/gnu/packages/libunwind.scm
index 5e690cf21c..ccbe2ec751 100644
--- a/gnu/packages/libunwind.scm
+++ b/gnu/packages/libunwind.scm
@@ -22,8 +22,9 @@
(define-module (gnu packages libunwind)
#:use-module (guix packages)
- #:use-module (gnu packages)
#:use-module (guix download)
+ #:use-module (guix utils)
+ #:use-module (gnu packages)
#:use-module (guix build-system gnu)
#:use-module (guix licenses))
@@ -40,10 +41,13 @@
"0xj9g6a9q7v7zz6lymf3f6011synibgawi4wi384bywid5kfqsja"))))
(build-system gnu-build-system)
(arguments
- '(#:make-flags
- ;; Two tests are failing with newer toolchains:
+ `(;; Two tests are failing with newer toolchains:
;; https://github.com/libunwind/libunwind/issues/363
- '("XFAIL_TESTS=run-coredump-unwind run-coredump-unwind-mdi")))
+ #:make-flags
+ '("XFAIL_TESTS=run-coredump-unwind run-coredump-unwind-mdi")
+ ;; A different collection of tests fails for each architecture.
+ #:tests? ,(and (not (%current-target-system))
+ (target-x86-64?))))
(home-page "https://www.nongnu.org/libunwind")
(synopsis "Determining the call chain of a program")
(description