aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ruby.scm22
1 files changed, 22 insertions, 0 deletions
diff --git a/gnu/packages/ruby.scm b/gnu/packages/ruby.scm
index e899d995fa..d9b513186a 100644
--- a/gnu/packages/ruby.scm
+++ b/gnu/packages/ruby.scm
@@ -7551,6 +7551,28 @@ from the YAML format.")
(home-page "https://github.com/ruby/psych")
(license license:expat)))
+(define-public ruby-psych-3
+ (package
+ (inherit ruby-psych)
+ (version "3.3.4")
+ (source (origin
+ (method git-fetch) ;for tests
+ (uri (git-reference
+ (url "https://github.com/ruby/psych")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name "ruby-psych" version))
+ (sha256
+ (base32
+ "11f7bxbhaj5697izap7hfbiln6lfk5cks78a498mkyhs2ylhl0fc"))))
+ (arguments
+ (list
+ #:phases
+ #~(modify-phases %standard-phases
+ (replace 'check
+ (lambda* (#:key tests? #:allow-other-keys)
+ (when tests?
+ (invoke "bundle" "exec" "rake" "default")))))))))
+
(define-public ruby-utils
(package
(name "ruby-utils")