aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/gawk.scm7
1 files changed, 7 insertions, 0 deletions
diff --git a/gnu/packages/gawk.scm b/gnu/packages/gawk.scm
index 436f0f435c..cea58bd415 100644
--- a/gnu/packages/gawk.scm
+++ b/gnu/packages/gawk.scm
@@ -25,6 +25,7 @@
#:use-module (gnu packages)
#:use-module (gnu packages base)
#:use-module (gnu packages bash)
+ #:use-module (gnu packages bison)
#:use-module (gnu packages gcc)
#:use-module (gnu packages libsigsegv)
#:use-module (gnu packages multiprecision)
@@ -148,11 +149,17 @@ block-scoped lexical variables."))))
(modules '((guix build utils)))
(snippet
'(begin
+ ;; Delete file generated by bison.
+ (delete-file "parse.c")
;; Prevent tests from hard coding PATH to a bogus value.
(substitute* '("test/mawktest" "test/fpe_test")
(("^PATH=.*")
""))))))
(build-system gnu-build-system)
+ (arguments
+ (list #:parallel-build? #f)) ; Prevent a race condition.
+ (native-inputs
+ (list bison))
(synopsis "Text scanning and processing language")
(description
"@command{mawk} is an interpreter for the Awk programming language.