aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/crates-graphics.scm27
1 files changed, 23 insertions, 4 deletions
diff --git a/gnu/packages/crates-graphics.scm b/gnu/packages/crates-graphics.scm
index caeb8d93bc..4ff77c6aef 100644
--- a/gnu/packages/crates-graphics.scm
+++ b/gnu/packages/crates-graphics.scm
@@ -3243,25 +3243,44 @@ in AVIF format (powers the @code{cavif} tool).")
(description "Interop library between Metal and raw-window-handle.")
(license (list license:expat license:asl2.0))))
-(define-public rust-resize-0.4
+(define-public rust-resize-0.7
(package
(name "rust-resize")
- (version "0.4.3")
+ (version "0.7.4")
(source
(origin
(method url-fetch)
(uri (crate-uri "resize" version))
(file-name (string-append name "-" version ".tar.gz"))
(sha256
- (base32 "0bamrw2m37l8q46mcy6snp6106d93dq7x67hbbj32w88pjdhxn84"))))
+ (base32 "0hdd5r2m1700y6r88v5hq3q28xixrsbfhbzqz26409jyy3zvvrw7"))))
(build-system cargo-build-system)
(arguments
- `(#:cargo-development-inputs (("rust-png" ,rust-png-0.16))))
+ `(#:cargo-inputs
+ (("rust-fallible-collections" ,rust-fallible-collections-0.4)
+ ("rust-rgb" ,rust-rgb-0.8))
+ #:cargo-development-inputs
+ (("rust-png" ,rust-png-0.17))))
(home-page "https://github.com/PistonDevelopers/resize")
(synopsis "Image resampling library in pure Rust")
(description "This package provides an image resampling library in pure Rust.")
(license license:expat)))
+(define-public rust-resize-0.4
+ (package
+ (inherit rust-resize-0.7)
+ (name "rust-resize")
+ (version "0.4.3")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (crate-uri "resize" version))
+ (file-name (string-append name "-" version ".tar.gz"))
+ (sha256
+ (base32 "0bamrw2m37l8q46mcy6snp6106d93dq7x67hbbj32w88pjdhxn84"))))
+ (arguments
+ `(#:cargo-development-inputs (("rust-png" ,rust-png-0.16))))))
+
(define-public rust-rgb-0.8
(package
(name "rust-rgb")