aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/cran.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/cran.scm b/gnu/packages/cran.scm
index 5bd5c60d49..67a1950756 100644
--- a/gnu/packages/cran.scm
+++ b/gnu/packages/cran.scm
@@ -10839,3 +10839,32 @@ using @code{S3}.")
for model selection. The calibration methods available are based on the slope
heuristics.")
(license license:gpl2+)))
+
+(define-public r-dorng
+ (package
+ (name "r-dorng")
+ (version "1.7.1")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (cran-uri "doRNG" version))
+ (sha256
+ (base32
+ "1sb75aqkliprglfxc4x4wds6alqgzhvl2n812g1d32a88ra3slr7"))))
+ (properties `((upstream-name . "doRNG")))
+ (build-system r-build-system)
+ (propagated-inputs
+ `(("r-foreach" ,r-foreach)
+ ("r-iterators" ,r-iterators)
+ ("r-pkgmaker" ,r-pkgmaker)
+ ("r-rngtools" ,r-rngtools)))
+ (home-page "https://renozao.github.io/doRNG/")
+ (synopsis "Generic reproducible parallel backend for foreach loops")
+ (description
+ "This package provides functions to perform reproducible parallel
+@code{foreach} loops, using independent random streams as generated by
+L'Ecuyer's combined multiple-recursive generator. It enables to easily
+convert standard @code{%dopar%} loops into fully reproducible loops,
+independently of the number of workers, the task scheduling strategy, or the
+chosen parallel environment and associated foreach backend.")
+ (license license:gpl2+)))