aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/kde-frameworks.scm10
1 files changed, 9 insertions, 1 deletions
diff --git a/gnu/packages/kde-frameworks.scm b/gnu/packages/kde-frameworks.scm
index 53fe0d814f..88f79615f0 100644
--- a/gnu/packages/kde-frameworks.scm
+++ b/gnu/packages/kde-frameworks.scm
@@ -2370,7 +2370,15 @@ integrated it into your application's other widgets.")
#:phases
#~(modify-phases %standard-phases
(add-before 'check 'check-setup
- (lambda _ (setenv "HOME" (getcwd)))))))
+ (lambda _ (setenv "HOME" (getcwd))))
+ (replace 'check
+ (lambda* (#:key tests? parallel-tests? #:allow-other-keys)
+ (when tests?
+ (invoke "ctest" "-E" "(kcontacts-addresstest)"
+ "--rerun-failed" "--output-on-failure"
+ "-j" (if parallel-tests?
+ (number->string (parallel-job-count))
+ "1"))))))))
(home-page "https://community.kde.org/Frameworks")
(synopsis "API for contacts/address book data following the vCard standard")
(description "This library provides a vCard data model, vCard