aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang-xyz.scm34
1 files changed, 34 insertions, 0 deletions
diff --git a/gnu/packages/golang-xyz.scm b/gnu/packages/golang-xyz.scm
index 45af26b38c..78bd492bfa 100644
--- a/gnu/packages/golang-xyz.scm
+++ b/gnu/packages/golang-xyz.scm
@@ -25,6 +25,7 @@
;;; Copyright © 2022 (unmatched-parenthesis <paren@disroot.org>
;;; Copyright © 2022 Dhruvin Gandhi <contact@dhruvin.dev>
;;; Copyright © 2022 Dominic Martinez <dom@dominicm.dev>
+;;; Copyright © 2022 Leo Nikkilä <hello@lnikki.la>
;;; Copyright © 2022 kiasoc5 <kiasoc5@disroot.org>
;;; Copyright © 2023 Benjamin <benjamin@uvy.fr>
;;; Copyright © 2023 Fries <fries1234@protonmail.com>
@@ -892,6 +893,39 @@ optimized for sparse nodes of
for Go.")
(license license:asl2.0)))
+(define-public go-github-com-asaskevich-govalidator
+ (package
+ (name "go-github-com-asaskevich-govalidator")
+ (version "11.0.1")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/asaskevich/govalidator")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "0aab1pym5c6di8vidynp6ly5j4kcqv6lp2737gw0a07zng0nn8lw"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/asaskevich/govalidator"
+ #:phases
+ #~(modify-phases %standard-phases
+ (add-after 'unpack 'disable-failing-tests
+ (lambda* (#:key tests? import-path #:allow-other-keys)
+ (with-directory-excursion (string-append "src/" import-path)
+ (substitute* (find-files "." "\\_test.go$")
+ ;; XXX: Some validation are failed in the test.
+ (("TestIsExistingEmail") "OffTestIsExistingEmail"))))))))
+ (home-page "https://github.com/asaskevich/govalidator")
+ (synopsis "Collection of various validators for Golang")
+ (description
+ "This package provides validators and sanitizers for strings, structs and
+collections. It was based on
+@url{https://github.com/chriso/validator.js,validator.js}.")
+ (license license:expat)))
+
(define-public go-github-com-audriusbutkevicius-recli
(package
(name "go-github-com-audriusbutkevicius-recli")