aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/ipfs.scm27
1 files changed, 27 insertions, 0 deletions
diff --git a/gnu/packages/ipfs.scm b/gnu/packages/ipfs.scm
index 10f4a6f0e4..a471da1b2f 100644
--- a/gnu/packages/ipfs.scm
+++ b/gnu/packages/ipfs.scm
@@ -398,6 +398,33 @@ throughout its lifetime.")
by @url{https://dgraph.io/docs/badger,Badger}.")
(license license:expat)))
+(define-public go-github-com-ipfs-go-ds-leveldb
+ (package
+ (name "go-github-com-ipfs-go-ds-leveldb")
+ (version "0.5.0")
+ (source
+ (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/ipfs/go-ds-leveldb")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32 "1hi7vmjpzzh00zcf0638rvgiqj4j8difz5kzr0pilr0z6zcb7dq3"))))
+ (build-system go-build-system)
+ (arguments
+ (list
+ #:import-path "github.com/ipfs/go-ds-leveldb"))
+ (propagated-inputs
+ (list go-github-com-ipfs-go-datastore go-github-com-syndtr-goleveldb))
+ (home-page "https://github.com/ipfs/go-ds-leveldb")
+ (synopsis "Implementation of go-datastore using leveldb")
+ (description
+ "This package implements the
+@url{https://github.com/ipfs/go-datastore,go-datastore} interface using a
+LevelDB backend.")
+ (license license:expat)))
+
(define-public go-github-com-ipfs-go-detect-race
(package
(name "go-github-com-ipfs-go-detect-race")