aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/package-management.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/package-management.scm b/gnu/packages/package-management.scm
index ea671c0760..c22c9f7a43 100644
--- a/gnu/packages/package-management.scm
+++ b/gnu/packages/package-management.scm
@@ -850,7 +850,7 @@ features of Stow with some extensions.")
(define-public rpm
(package
(name "rpm")
- (version "4.17.0")
+ (version "4.17.1")
(source (origin
(method url-fetch)
(uri (string-append "http://ftp.rpm.org/releases/rpm-"
@@ -858,7 +858,7 @@ features of Stow with some extensions.")
version ".tar.bz2"))
(sha256
(base32
- "0sjyqs6hc57k46f45b68dfxnp985s0gar0fi1s0ig6vl4h5j439f"))))
+ "0pbfj94ha59lbnd8dk0aqyxjv37xixfdcazq3y2mhwkf8s9vf48c"))))
(build-system gnu-build-system)
(arguments
'(#:configure-flags '("--with-external-db" ;use the system's bdb
CHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the ;;; GNU General Public License for more details. ;;; ;;; You should have received a copy of the GNU General Public License ;;; along with GNU Guix. If not, see <http://www.gnu.org/licenses/>. (define-module (gnu packages scanner) #:use-module (guix packages) #:use-module (guix download) #:use-module (guix build-system gnu) #:use-module (gnu packages pkg-config) #:use-module (gnu packages libusb) #:use-module ((guix licenses) #:prefix licence:)) (define-public sane-backends (package (name "sane-backends") (version "1.0.25") (source (origin (method url-fetch) (uri (string-append "https://alioth.debian.org/frs/download.php/file/4146/" name "-" version ".tar.gz")) (sha256 (base32 "0b3fvhrxl4l82bf3v0j47ypjv6a0k5lqbgknrq1agpmjca6vmmx4")))) (build-system gnu-build-system) (native-inputs `(("pkg-config" ,pkg-config))) (inputs `(("libusb-compat" ,libusb-compat))) (arguments `(#:tests? #f #:phases (modify-phases %standard-phases (add-before 'configure 'disable-backends (lambda _ (setenv "BACKENDS" " ") #t)) (add-after 'install 'install-udev-rules (lambda* (#:key outputs #:allow-other-keys) (let ((out (assoc-ref outputs "out"))) (mkdir-p (string-append out "/lib/udev/rules.d")) (copy-file "tools/udev/libsane.rules" (string-append out "/lib/udev/rules.d/" "60-libsane.rules")))))))) ;; It would seem that tests are not maintained - fails with ;; the following: ;; ;; < This page was last updated on Wed Jul 31 07:52:48 2013 ;; < by sane-desc 3.5 from sane-backends 1.0.24git ;; --- ;; > This page was last updated on Sun Oct 19 15:41:39 2014 ;; > by sane-desc 3.5 from sane-backends 1.0.24 ;; **** File generated for html-backends-split mode is different from reference ;; Makefile:501: recipe for target 'check.local' failed (home-page "http://www.sane-project.org") (synopsis "Raster image scanner library and drivers") (description "SANE stands for \"Scanner Access Now Easy\" and is an API proving access to any raster image scanner hardware (flatbed scanner, hand-held scanner, video- and still-cameras, frame-grabbers, etc.). The package contains the library and drivers.") (license licence:gpl2+))) ; plus linking exception