aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/check.scm2
-rw-r--r--gnu/packages/golang-build.scm11
-rw-r--r--gnu/packages/version-control.scm2
3 files changed, 2 insertions, 13 deletions
diff --git a/gnu/packages/check.scm b/gnu/packages/check.scm
index 8a8a8f16a0..550a5d0f1d 100644
--- a/gnu/packages/check.scm
+++ b/gnu/packages/check.scm
@@ -1064,7 +1064,7 @@ but it works for any C/C++ project.")
go-github-com-mattn-go-runewidth
go-github-com-robfig-cron
go-golang-org-x-sync
- go-golang.org-x-sync-semaphore
+ go-golang-org-x-sync
go-gopkg-in-yaml-v3))
(native-inputs (list go-github-com-google-go-cmp-cmp))
(home-page "https://rhysd.github.io/actionlint/")
diff --git a/gnu/packages/golang-build.scm b/gnu/packages/golang-build.scm
index d69746a9be..d8dcde3759 100644
--- a/gnu/packages/golang-build.scm
+++ b/gnu/packages/golang-build.scm
@@ -293,17 +293,6 @@ addition to the ones provided by the language and “sync” and “sync/atomic
packages.")
(license license:bsd-3))))
-(define-public go-golang.org-x-sync-semaphore
- (package
- (inherit go-golang-org-x-sync)
- (name "go-golang.org-x-sync-semaphore")
- (arguments
- '(#:import-path "golang.org/x/sync/semaphore"
- #:unpack-path "golang.org/x/sync"))
- (home-page "https://godoc.org/golang.org/x/sync/semaphore")
- (synopsis "Weighted semaphore implementation in Go")
- (description "Weighted semaphore implementation in Go.")))
-
(define-public go-golang-org-x-sys
(let ((commit "ca59edaa5a761e1d0ea91d6c07b063f85ef24f78")
(revision "0"))
diff --git a/gnu/packages/version-control.scm b/gnu/packages/version-control.scm
index 22e281bc3d..29401f87ff 100644
--- a/gnu/packages/version-control.scm
+++ b/gnu/packages/version-control.scm
@@ -3505,7 +3505,7 @@ will reconstruct the object along its delta-base chain and return it.")
go-github-com-xeipuuv-gojsonreference
go-github-com-xeipuuv-gojsonpointer
go-golang-org-x-net
- go-golang.org-x-sync-semaphore
+ go-golang-org-x-sync
go-github-com-ssgelm-cookiejarparser
go-github-com-rubyist-tracerx
go-github-com-olekukonko-ts