aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e6b66f088a..ce424675bd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4979,6 +4979,29 @@ complexity of Python source code.")
(define-public python2-flake8
(package-with-python2 python-flake8))
+;; This will only be needed by the python-hacking package and will not be
+;; necessary once python-hacking > 0.10.2 is released.
+(define-public python-flake8-2.2.4
+ (package (inherit python-flake8)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pep8" ,python-pep8-1.5.7)
+ ("python-pyflakes" ,python-pyflakes-0.8.1)
+ ("python-mccabe" ,python-mccabe-0.2.1)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (version "2.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "1r9wsry4va45h1rck5hxd3vzsg2q3y6lnl6pym1bxvz8ry19jwx8"))))))
+
+(define-public python2-flake8-2.2.4
+ (package-with-python2 python-flake8-2.2.4))
+
(define-public python-mistune
(package
(name "python-mistune")
packages/python-web.scm, gnu/packages/python-xyz.scm, gnu/packages/python.scm, gnu/packages/qt.scm, gnu/packages/ruby.scm, gnu/packages/rust.scm, gnu/packages/scheme.scm, gnu/packages/serialization.scm, gnu/packages/shells.scm, gnu/packages/ssh.scm, gnu/packages/suckless.scm, gnu/packages/tbb.scm, gnu/packages/telephony.scm, gnu/packages/text-editors.scm, gnu/packages/textutils.scm, gnu/packages/time.scm, gnu/packages/tls.scm, gnu/packages/tor.scm, gnu/packages/version-control.scm, gnu/packages/video.scm, gnu/packages/vim.scm, gnu/packages/web.scm, gnu/packages/wm.scm, gnu/packages/xdisorg.scm, gnu/packages/xfce.scm, gnu/packages/xml.scm, gnu/packages/xorg.scm, gnu/services/certbot.scm, gnu/services/desktop.scm, gnu/services/version-control.scm, gnu/services/web.scm, guix/import/hackage.scm, guix/licenses.scm: Correct name and email address for ng0. Signed-off-by: Tobias Geerinckx-Rice <me@tobias.gr> ng0 2018-08-16gnu: Use ©....* gnu/packages/elixir.scm: Replace missing © with ©. * gnu/packages/erlang.scm: Likewise. * gnu/packages/marst.scm: Ditto. Tobias Geerinckx-Rice 2018-07-17gnu: elixir: Update to 1.6.6....* gnu/packages/elixir.scm (elixir): Update to 1.6.6. Signed-off-by: Nils Gillmann <gillmann@infotropique.org> Signed-off-by: Ludovic Courtès <ludo@gnu.org> Nils Gillmann 2018-06-12gnu: elixir: Enable more tests and remove patch....Previously, due to issues in the erlang package, many tests would fail, and the package would also nondeterministically fail to build. This is now fixed (by patching occurrences of /bin/sh in the erlang package), so all the tests can be run. * gnu/packages/elixir.scm (elixir)[source]: Remove patches. [arguments]: Remove the fix-or-disable-tests phase. Add a new set-home phase to set the HOME environment variable prior to running the tests. * gnu/packages/patches/elixir-disable-failing-tests.patch: Delete this file. * gnu/local.mk: Remove now deleted patch. Christopher Baines