aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorCyril Roelandt <tipecaml@gmail.com>2015-10-11 05:21:12 +0200
committerCyril Roelandt <tipecaml@gmail.com>2015-11-03 21:38:13 +0100
commitabf21efcae3bb52b463c6b92f7b9132ba1c0bfa8 (patch)
tree3cbbacd5df751a89425c87a6e1f1db17f41cd5bf
parent7477fbb1bed276b9cf2252126ad9ae9b2ed7e669 (diff)
downloadguix-abf21efcae3bb52b463c6b92f7b9132ba1c0bfa8.tar.gz
guix-abf21efcae3bb52b463c6b92f7b9132ba1c0bfa8.zip
gnu: Add python-flake8-2.2.4
* gnu/packages/python.scm (python-flake8-2.2.4, python2-flake8-2.2.4): New variables.
-rw-r--r--gnu/packages/python.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/python.scm b/gnu/packages/python.scm
index e6b66f088a..ce424675bd 100644
--- a/gnu/packages/python.scm
+++ b/gnu/packages/python.scm
@@ -4979,6 +4979,29 @@ complexity of Python source code.")
(define-public python2-flake8
(package-with-python2 python-flake8))
+;; This will only be needed by the python-hacking package and will not be
+;; necessary once python-hacking > 0.10.2 is released.
+(define-public python-flake8-2.2.4
+ (package (inherit python-flake8)
+ (inputs
+ `(("python-setuptools" ,python-setuptools)
+ ("python-pep8" ,python-pep8-1.5.7)
+ ("python-pyflakes" ,python-pyflakes-0.8.1)
+ ("python-mccabe" ,python-mccabe-0.2.1)
+ ("python-mock" ,python-mock)
+ ("python-nose" ,python-nose)))
+ (version "2.2.4")
+ (source
+ (origin
+ (method url-fetch)
+ (uri (pypi-uri "flake8" version))
+ (sha256
+ (base32
+ "1r9wsry4va45h1rck5hxd3vzsg2q3y6lnl6pym1bxvz8ry19jwx8"))))))
+
+(define-public python2-flake8-2.2.4
+ (package-with-python2 python-flake8-2.2.4))
+
(define-public python-mistune
(package
(name "python-mistune")
system.scm (arguments->manifests, manifests->packages): New procedures. (hydra-jobs): Add a "manifests" subset. * doc/guix.texi (Continuous Integration): Update accordingly. Clément Lassieur 2018-06-15hydra: Make sure we add an absolute file name to the load path....Previously, under Cuirass, we'd add "build-aux/cuirass/../hydra/../..". But then, commit c45477d2a1a651485feede20fe0f3d15aec48b39 added this in (gnu system vm): (local-file (search-path %load-path "guix/store/schema.sql")) Since 'search-path' would not return an absolute file name, 'local-file' would try to resolve that relative to "gnu/system", leading to: ERROR: In procedure force: In procedure canonicalize-path: No such file or directory: "/gnu/store/…-guix-ce573b1/gnu/system/build-aux/cuirass/../hydra/../../guix/store/schema.sql * build-aux/hydra/gnu-system.scm <top level>: Canonicalize DIR before adding it to %LOAD-PATH. Ludovic Courtès 2018-05-12hydra: Switch back to "-" instead of "@" in package job names....Fixes a regression introduced in ede121de426f9c56820852888a0b370f0ccbce49. Reported by Mark H Weaver <mhw@netris.org>. * build-aux/hydra/gnu-system.scm (job-name): Pass "-" as the second argument to 'package-full-name'. Ludovic Courtès 2018-04-09hydra: Fix uses of 'eval-when'....* build-aux/hydra/gnu-system.scm: Use (expand load eval) in 'eval-when' clause so as to not poison a cat and to ensure %load-compiled-path is properly set when the 'use-modules' clauses are expanded. * build-aux/hydra/guix.scm: Likewise. Ludovic Courtès 2018-04-08hydra: Clear '%load-compiled-path' for gnu-system.scm....On hydra.gnu.org GUILE_LOAD_COMPILED_PATH happened to be empty so we were fine. However on GuixSD with Cuirass, we could have a conflicting non-empty path and .go files for some of the (guix …) and (gnu …) modules would be taken from there. * build-aux/hydra/gnu-system.scm: Set %load-compiled-path. Ludovic Courtès 2018-02-01Merge branch 'master' into core-updatesMarius Bakke 2018-01-29hydra: Fix up arm qemu job....* build-aux/hydra/gnu-system.scm (qemu-jobs): Fix up arm qemu job. Follow-up to 44b0303762f58badd9b9f8f1145e54b76b9d19d2. Danny Milosavljevic 2018-01-29hydra: Only build the "flash image" on arm....* build-aux/hydra/gnu-system.scm (qemu-jobs): Only build the "flash image" on arm. Danny Milosavljevic 2018-01-29hydra: Work around import problem....* build-aux/hydra/gnu-system.scm: qemu-jobs: Work around import problem. Follow-up to 1fe805b290f26db477bcd49be91af54f6c5d061f. Danny Milosavljevic 2018-01-29hydra: Add (gnu bootloader) import....* build-aux/hydra/gnu-system.scm: Add (gnu bootloader) import. Follow-up to de2bc8d6da0ba4e74ed083af66a22cf96f74e67f. Danny Milosavljevic 2018-01-29hydra: Add arm image builder....* build-aux/hydra/gnu-system.scm (%u-boot-systems): New variable. (%guixsd-supported-systems): Add armhf-linux. (qemu-jobs): Use u-boot if system in %u-boot-systems. Danny Milosavljevic 2018-01-21hydra: Make the list of target systems a parameter....* build-aux/hydra/gnu-system.scm (hydra-jobs): Define 'systems' and use it. Ludovic Courtès