aboutsummaryrefslogtreecommitdiff
diff options
context:
space:
mode:
-rw-r--r--gnu/packages/golang.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/golang.scm b/gnu/packages/golang.scm
index 7196ca5ec5..ded64e9c28 100644
--- a/gnu/packages/golang.scm
+++ b/gnu/packages/golang.scm
@@ -1407,6 +1407,30 @@ messages automatically.")
"Package reqtrace contains a very simple request tracing framework.")
(license license:asl2.0))))
+(define-public go-github-com-jcmturner-aescts-v2
+ (package
+ (name "go-github-com-jcmturner-aescts-v2")
+ (version "2.0.0")
+ (source (origin
+ (method git-fetch)
+ (uri (git-reference
+ (url "https://github.com/jcmturner/aescts")
+ (commit (string-append "v" version))))
+ (file-name (git-file-name name version))
+ (sha256
+ (base32
+ "0yrdiisdhcqfs8jpicc30dfmbqzxhkmbayn902xrgwkndky8w7l1"))))
+ (build-system go-build-system)
+ (arguments
+ '(#:import-path "github.com/jcmturner/aescts/v2"))
+ (propagated-inputs (list go-github-com-stretchr-testify))
+ (home-page "https://github.com/jcmturner/aescts")
+ (synopsis "Encrypt and decrypt data in Go using AES CipherText Stealing")
+ (description
+ "This package provides AES Cipher Block Chaining CipherText Stealing
+encryption and decryption methods.")
+ (license license:asl2.0)))
+
(define-public go-github-com-kataras-golog
(package
(name "go-github-com-kataras-golog")